aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-12-04 23:24:11 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-12-05 01:13:02 +0800
commit126a2e8cb45b797579876834a566cec51f4a16a8 (patch)
treea2073540866a86799077408b38469b552046ac31
parent7b64a96326bde6b51f887a96345ba89c115ceeae (diff)
downloadguix-126a2e8cb45b797579876834a566cec51f4a16a8.tar.gz
guix-126a2e8cb45b797579876834a566cec51f4a16a8.zip
Partial revert "gnu: bootstrap: %bootstrap-glibc: Also fix libm.so."
This partially reverts commit 204fe1b1f05f4438d1cf72c568b45696e55e54c9. This part accidentally triggered a world rebuild for non-x86 architectures. Change-Id: I921984ef5eff58792ffc17b64675db6a8e79695c
-rw-r--r--gnu/packages/bootstrap.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 226cf0804b..dcf385b03e 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -775,11 +775,14 @@ $out/bin/guile --version~%"
(chmod "lib" #o755)
;; Patch linker scripts so they refer to the right file-names.
- (substitute* ,(if (target-hurd64?)
- ''("lib/libc.so" "lib/libm.so")
- "lib/libc.so")
- (("/[^ ]+/lib/(libc|libm|libh|ld)" _ prefix)
- (string-append out "/lib/" prefix)))))))))
+ ,(if (target-hurd64?)
+ '(substitute* '("lib/libc.so" "lib/libm.so")
+ (("/[^ ]+/lib/(libc|libm|libh|ld)" _ prefix)
+ (string-append out "/lib/" prefix)))
+ '(substitute* "lib/libc.so"
+ (("/[^ ]+/lib/(libc|ld)" _ prefix)
+ (string-append out "/lib/" prefix))))
+ #t))))))
(inputs
`(("tar" ,(bootstrap-executable "tar" (%current-system)))
("xz" ,(bootstrap-executable "xz" (%current-system)))