aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2024-11-05 23:23:50 +0100
committerVagrant Cascadian <vagrant@debian.org>2024-12-10 22:34:24 -0800
commit1199a19ba7a1486ef016e8991d21d53e9c7eb990 (patch)
tree71020648f15fd983878b8e17ab2af8a08ccb9bae
parent65425efb3023f38a8700681ea7c6e9d81052a990 (diff)
downloadguix-1199a19ba7a1486ef016e8991d21d53e9c7eb990.tar.gz
guix-1199a19ba7a1486ef016e8991d21d53e9c7eb990.zip
gnu: Fix synopsis in various haskell packages.
* gnu/packages/haskell-apps.scm (scroll): Fix synopsis. * gnu/packages/haskell-crypto.scm (ghc-curve25519): Fix synopsis. * gnu/packages/haskell-xyz.scm (ghc-base-compat-batteries): Fix synopsis. (ghc-generic-lens-core): Fix synopsis. (ghc-generic-lens): Fix synopsis. (ghc-skylighting): Fix synopsis. (ghc-git-lfs): Fix synopsis. (ghc-barbies): Fix synopsis. (ghc-witherable): Fix synopsis. (ghc-pcg-random): Fix synopsis. (ghc-ordered-containers): Fix synopsis. (ghc-cabal-syntax): Fix synopsis. (ghc-tasty-hslua): Fix synopsis. (ghc-hslua-marshalling): Fix synopsis. (ghc-lua-arbitrary): Fix synopsis. (ghc-hslua-aeson): Fix synopsis. (ghc-gridtables): Fix synopsis. (ghc-servant): Fix synopsis. (ghc-servant-server): Fix synopsis. (ghc-hslua-packaging): Fix synopsis. (ghc-hslua-module-version): Fix synopsis. Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
-rw-r--r--gnu/packages/haskell-apps.scm2
-rw-r--r--gnu/packages/haskell-crypto.scm2
-rw-r--r--gnu/packages/haskell-xyz.scm39
3 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 1f5d1d74d3..1ef3ed4035 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -920,7 +920,7 @@ is programmed in Haskell.")
ghc-random
ghc-vector))
(home-page "https://joeyh.name/code/scroll/")
- (synopsis "scroll(6), a roguelike game")
+ (synopsis "Roguelike game")
(description
"You're a bookworm that's stuck on a scroll. You have to dodge between
words and use spells to make your way down the page as the scroll is read. Go
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 7ea9cf1e12..25867b3895 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -312,7 +312,7 @@ generators, and more.")
(list ghc-crypto-api))
(properties '((upstream-name . "curve25519")))
(home-page "https://github.com/acw/curve25519")
- (synopsis "Fast implementations of the curve25519 elliptic curve primitives.")
+ (synopsis "Fast implementations of the curve25519 elliptic curve primitives")
(description
"This module provides Haskell bindings and extensions to the curve25519-donna
codebase. It's a pretty straightforward implementation of the basic
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index ae1aa2d334..3915bf29b0 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -779,7 +779,7 @@ pragmas in your code.")
(inputs (list ghc-base-compat))
(native-inputs (list ghc-hspec ghc-quickcheck hspec-discover))
(home-page "https://hackage.haskell.org/package/base-compat-batteries")
- (synopsis "base-compat with extra batteries")
+ (synopsis "Extra batteries included base-compat")
(description
"This library provides functions available in later
versions of @code{base} to a wider range of compilers, without requiring
@@ -6559,7 +6559,7 @@ lenses and traversals for those who require Haskell 98.")
`(#:cabal-revision ("1"
"1dbjhd6k7ypqa9f4h9v2xndgb4mjhfli3n1vjm8r8ga0kfndbqfn")))
(home-page "https://github.com/kcsongor/generic-lens")
- (synopsis "Generically derive traversals, lenses and prisms.")
+ (synopsis "Generically derive traversals, lenses and prisms")
(description
"This library uses GHC.Generics to derive efficient optics (traversals,
lenses and prisms) for algebraic data types in a type-directed way, with a
@@ -6583,7 +6583,7 @@ is the shared internal logic of the @code{generic-lens} and
(inputs (list ghc-generic-lens-core ghc-profunctors))
(native-inputs (list ghc-lens ghc-inspection-testing ghc-hunit ghc-doctest))
(home-page "https://github.com/kcsongor/generic-lens")
- (synopsis "Generically derive traversals, lenses and prisms.")
+ (synopsis "Generically derive traversals, lenses and prisms")
(description
"This library uses @code{GHC.Generics} to derive efficient
optics (traversals, lenses and prisms) for algebraic data types in a
@@ -11426,7 +11426,7 @@ colored text.")
ghc-pretty-show
ghc-blaze-html))
(home-page "https://github.com/jgm/skylighting")
- (synopsis "syntax highlighting library")
+ (synopsis "Syntax highlighting library")
(description
"Skylighting is a syntax highlighting library with support for over one hundred
languages. It derives its tokenizers from XML syntax definitions used by KDE's
@@ -15980,7 +15980,7 @@ highlighting and display the results in Brick-based interfaces.")
(inputs (list ghc-http-client ghc-http-types ghc-aeson ghc-network-uri
ghc-case-insensitive))
(home-page "https://hackage.haskell.org/package/git-lfs")
- (synopsis "git-lfs protocol")
+ (synopsis "Git Large File Storage protocol")
(description "An implementation of the git-lfs protocol.")
(license license:agpl3)))
@@ -16038,7 +16038,7 @@ tracking down existing ones.")
ghc-tasty-hunit
ghc-tasty-quickcheck))
(home-page "https://github.com/jcpetruzza/barbies#readme")
- (synopsis "Classes for working with types that can change clothes.")
+ (synopsis "Classes for working with types that can change clothes")
(description
"Types that are parametric on a functor are like Barbies that have an outfit for
each role. This package provides the basic abstractions to work with them
@@ -16126,7 +16126,7 @@ dependencies.")
`(#:cabal-revision ("3"
"1f2bvl41by904lnr0dk6qgasqwadq2w48l7fj51bp2h8bqbkdjyc")))
(home-page "https://github.com/fumieval/witherable")
- (synopsis "filterable traversable")
+ (synopsis "Filterable traversable")
(description
"This package provides a stronger variant of `traverse` which can remove elements
and generalised mapMaybe, catMaybes, filter")
@@ -16209,7 +16209,7 @@ Documentation is at
`(#:cabal-revision ("1"
"1f8h0lv34cmqaxccg2yf6q4s8r5g2s8q8s9kql212iggd2l3vv77")))
(home-page "https://github.com/cchalmers/pcg-random")
- (synopsis "Haskell bindings to the PCG random number generator.")
+ (synopsis "Haskell bindings to the PCG random number generator")
(description
"PCG is a family of simple fast space-efficient statistically good algorithms for
random number generation. Unlike many general-purpose RNGs, they are also hard
@@ -16300,9 +16300,8 @@ benchmarks](https://hackage.haskell.org/package/random-bytestring-0.1.3.2/src/be
(build-system haskell-build-system)
(properties '((upstream-name . "ordered-containers")))
(home-page "https://hackage.haskell.org/package/ordered-containers")
- (synopsis
- "Set- and Map-like types that remember the order elements were inserted")
(description "")
+ (synopsis "Haskell types")
(license license:bsd-3)))
(define-public ghc-cabal-syntax
@@ -16318,7 +16317,7 @@ benchmarks](https://hackage.haskell.org/package/random-bytestring-0.1.3.2/src/be
(build-system haskell-build-system)
(properties '((upstream-name . "Cabal-syntax")))
(home-page "https://www.haskell.org/cabal/")
- (synopsis "A library for working with .cabal files")
+ (synopsis "Library for working with .cabal files")
(description
"This library provides tools for reading and manipulating the .cabal file format.
. Version 3.6 (unlike the following versions) is a dummy package that prevents
@@ -16346,7 +16345,7 @@ requiring Cabal or Cabal-syntax >= 3.7")
(properties '((upstream-name . "tasty-hslua")))
(inputs (list ghc-hslua-core ghc-tasty ghc-tasty-hunit))
(home-page "https://hslua.org/")
- (synopsis "Tasty helpers to test HsLua.")
+ (synopsis "Tasty helpers to test HsLua")
(description
"Various tasty helpers and utilities to test HsLua oparations. Built on top of
tasty-hunit.")
@@ -16373,7 +16372,7 @@ tasty-hunit.")
ghc-tasty-hunit
ghc-tasty-quickcheck))
(home-page "https://hslua.org/")
- (synopsis "Marshalling of values between Haskell and Lua.")
+ (synopsis "Marshalling of values between Haskell and Lua")
(description
"This package provides functions to marshal values from Haskell to Lua, and /vice
versa/. . This package is part of HsLua, a Haskell framework built around the
@@ -16394,7 +16393,7 @@ embeddable scripting language <https://lua.org Lua>.")
(properties '((upstream-name . "lua-arbitrary")))
(inputs (list ghc-lua ghc-quickcheck))
(home-page "https://hslua.org/")
- (synopsis "Arbitrary instances for Lua types.")
+ (synopsis "Arbitrary instances for Lua types")
(description
"This package provides instances for QuickCheck's \\\"Arbitrary\\\" typeclass.")
(license license:expat)))
@@ -16472,7 +16471,7 @@ Haskell program.")
(native-inputs (list ghc-quickcheck ghc-quickcheck-instances ghc-tasty
ghc-tasty-quickcheck))
(home-page "https://hslua.org/")
- (synopsis "Allow aeson data types to be used with Lua.")
+ (synopsis "Allow aeson data types to be used with Lua")
(description
"This package provides instances to push and receive any datatype encodable as
JSON to and from the Lua stack.")
@@ -16496,7 +16495,7 @@ JSON to and from the Lua stack.")
`(#:cabal-revision ("1"
"0m2651z81n8s6hb8id7y6k2kprsgwnj7pcd6p8lmdpkzzz3wwd0c")))
(home-page "https://github.com/tarleb/gridtables")
- (synopsis "Parser for reStructuredText-style grid tables.")
+ (synopsis "Parser for reStructuredText-style grid tables")
(description
"This package provides a parser for plain-text representations of tables. This
package supports table headers, cells spanning multiple columns or rows, as well
@@ -16674,7 +16673,7 @@ readRequestBodyWith . mapContentMedia > [ (\"application/json\", parseJson) > ,
ghc-vault))
(native-inputs (list ghc-hspec ghc-quickcheck-instances hspec-discover))
(home-page "http://docs.servant.dev/")
- (synopsis "A family of combinators for defining webservices APIs")
+ (synopsis "Family of combinators for defining webservices APIs")
(description
"This package provides a family of combinators for defining webservices APIs and
serving them . You can learn about the basics in the
@@ -16812,7 +16811,7 @@ information, see the README.")
hspec-discover))
(home-page "http://docs.servant.dev/")
(synopsis
- "A family of combinators for defining webservices APIs and serving them")
+ "Family of combinators for defining webservices APIs and serving them")
(description
"This package provides a family of combinators for defining webservices APIs and
serving them . You can learn about the basics in the
@@ -16936,7 +16935,7 @@ are unsure which variant to use, use the one in \"Data.Some\" module.")
ghc-hslua-objectorientation))
(native-inputs (list ghc-tasty-hslua ghc-tasty ghc-tasty-hunit))
(home-page "https://hslua.org/")
- (synopsis "Utilities to build Lua modules.")
+ (synopsis "Utilities to build Lua modules")
(description
"Utilities to package up Haskell functions and values into a Lua module. . This
package is part of HsLua, a Haskell framework built around the embeddable
@@ -16958,7 +16957,7 @@ scripting language <https://lua.org Lua>.")
(inputs (list ghc-hslua-core ghc-hslua-marshalling ghc-hslua-packaging))
(native-inputs (list ghc-tasty ghc-tasty-hunit ghc-tasty-lua))
(home-page "https://hslua.org/")
- (synopsis "Lua module to work with version specifiers.")
+ (synopsis "Lua module to work with version specifiers")
(description "Wrapper for the Data.Version.Version Haskell type.")
(license license:expat)))