aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:47 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:36 +0200
commit1197e4e99944cbb2837462d92ba0bbf3a9a96ddc (patch)
treef5b226fde4c63ca1b927b4849a142fbedcdb3c37
parentd3973ed3745366c8204ac3aae004bb982b2cb506 (diff)
downloadguix-1197e4e99944cbb2837462d92ba0bbf3a9a96ddc.tar.gz
guix-1197e4e99944cbb2837462d92ba0bbf3a9a96ddc.zip
gnu: web-browsers: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/web-browsers.scm (luakit)[inputs]: Add 'bash-minimal'. (kristall): Delete trailing #t. [inputs]: Add 'bash-minimal'. (nyxt)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I8106374fc4d208dff19fa12c067772a189b97223
-rw-r--r--gnu/packages/web-browsers.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 7a14e6dfb5..a8c51b503b 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -264,7 +264,8 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
(native-inputs
(list pkg-config))
(inputs
- (list glib-networking
+ (list bash-minimal
+ glib-networking
gsettings-desktop-schemas
gtk+
lua-5.1
@@ -373,8 +374,7 @@ systems intended primarily for local access.")
;; Contains executable of 7z and pscp
(delete-file-recursively "ci/tools")
;; Remove bundled fonts
- (delete-file-recursively "src/fonts")
- #t))))
+ (delete-file-recursively "src/fonts")))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -394,22 +394,21 @@ systems intended primarily for local access.")
;; Patch it to just return the real version number directly.
(substitute* "src/kristall.pro"
(("(KRISTALL_VERSION=).*" _ match)
- (string-append match ,version "\n")))
- #t))
+ (string-append match ,version "\n")))))
(add-before 'build 'dont-use-bundled-cmark
(lambda _
(substitute* "src/kristall.pro"
(("(^include\\(.*cmark.*)" _ match)
(string-append
- "LIBS += -I" (assoc-ref %build-inputs "cmark") " -lcmark")))
- #t))
+ "LIBS += -I" (assoc-ref %build-inputs "cmark")
+ " -lcmark")))))
(add-before 'build 'dont-use-bundled-breeze-stylesheet
(lambda _
(substitute* "src/kristall.pro"
(("../lib/BreezeStyleSheets/breeze.qrc")
(string-append
- (assoc-ref %build-inputs "breeze-stylesheet") "/breeze.qrc")))
- #t))
+ (assoc-ref %build-inputs "breeze-stylesheet")
+ "/breeze.qrc")))))
(add-before 'build 'dont-use-bundled-fonts
(lambda _
(substitute* "src/kristall.pro"
@@ -422,8 +421,7 @@ systems intended primarily for local access.")
(("/fonts/NotoColorEmoji")
(string-append
(assoc-ref %build-inputs "font-google-noto")
- "/share/fonts/truetype/NotoColorEmoji")))
- #t))
+ "/share/fonts/truetype/NotoColorEmoji")))))
(add-after 'install 'wrap-program
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -445,7 +443,8 @@ systems intended primarily for local access.")
(base32
"1kvkxkisi3czldnb43ig60l55pi4a3m2a4ixp7krhpf9fc5wp294")))))))
(inputs
- (list cmark
+ (list bash-minimal
+ cmark
font-google-noto
font-openmoji
openssl
@@ -617,7 +616,7 @@ driven and does not detract you from your daily work.")
(add-before 'build 'fix-common-lisp-cache-folder
(lambda _ (setenv "HOME" "/tmp")))
(add-before 'check 'configure-tests
- (lambda _ (setenv "NYXT_TESTS_NO_NETWORK" "1") #t))
+ (lambda _ (setenv "NYXT_TESTS_NO_NETWORK" "1")))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((bin (string-append (assoc-ref outputs "out") "/bin/nyxt"))
@@ -641,7 +640,8 @@ driven and does not detract you from your daily work.")
`("LD_LIBRARY_PATH" ":" prefix (,path))
`("XDG_DATA_DIRS" ":" prefix (,xdg-path)))))))))
(native-inputs (list cl-lisp-unit2 sbcl))
- (inputs (list sbcl-alexandria
+ (inputs (list bash-minimal
+ sbcl-alexandria
sbcl-bordeaux-threads
sbcl-calispel
sbcl-cl-base64