aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:50:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:55 +0200
commit1053084b23553b69c1666b810e574549f34a5fc5 (patch)
tree5f8557b611742f1dacb2602a846ef9f3cf66ef80
parentd9d72c834e3bf89cd0304c8a8bfa2ffe826faa1c (diff)
downloadguix-1053084b23553b69c1666b810e574549f34a5fc5.tar.gz
guix-1053084b23553b69c1666b810e574549f34a5fc5.zip
gnu: texlive-ltxcmds: Refresh package definition.
* gnu/packages/tex.scm (texlive-ltxcmds): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 19 insertions, 23 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2ee2df0b1b..961e40c5a4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9735,29 +9735,25 @@ interface.")
(define-deprecated-package texlive-generic-listofitems texlive-listofitems)
(define-public texlive-ltxcmds
- (let ((template (simple-texlive-package
- "texlive-ltxcmds"
- (list "doc/generic/ltxcmds/"
- "source/generic/ltxcmds/"
- "tex/generic/ltxcmds/")
- (base32
- "1izcw9jl64iij541183hc156sjwamvxm7q9fkpfnz8sppyg31fkb"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "generic/ltxcmds")
- ((#:build-targets _ '())
- #~(list "ltxcmds.dtx"))))
- (home-page "https://www.ctan.org/pkg/ltxcmds")
- (synopsis "LaTeX kernel commands extracted for general use")
- (description
- "This package exports some utility macros from the LaTeX kernel into
-a separate namespace and also makes them available for other formats such
-as plain TeX.")
- (license license:lppl1.3c+))))
+ (package
+ (name "texlive-ltxcmds")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/ltxcmds/"
+ "source/generic/ltxcmds/"
+ "tex/generic/ltxcmds/")
+ (base32
+ "1izcw9jl64iij541183hc156sjwamvxm7q9fkpfnz8sppyg31fkb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ltxcmds")
+ (synopsis "Some LaTeX kernel commands for general use")
+ (description
+ "This package exports some utility macros from the LaTeX kernel into
+a separate namespace and also makes them available for other formats such as
+plain TeX.")
+ (license license:lppl1.3+)))
(define-deprecated-package texlive-generic-ltxcmds texlive-ltxcmds)