aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-23 15:47:52 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-23 17:05:18 +0100
commit0f7a5ae887017aa6dc33a661aa238d33e6eab640 (patch)
treef20f17c402591ca6af663f82d79aa21a7657e209
parent064a6e1f907d7c277aee3b6bd848774efdacb111 (diff)
downloadguix-0f7a5ae887017aa6dc33a661aa238d33e6eab640.tar.gz
guix-0f7a5ae887017aa6dc33a661aa238d33e6eab640.zip
gnu: go-github-com-google-renameio: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-google-renameio, go-github-com-google-renameio-v2): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I38a9f57ab28501b87d517e098d6afdc0c414f6e9
-rw-r--r--gnu/packages/golang-xyz.scm42
-rw-r--r--gnu/packages/golang.scm39
2 files changed, 42 insertions, 39 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c4d398fd92..0b9ebde3e1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Brian Kubisiak <brian@kubisiak.com>
;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
@@ -2680,6 +2681,47 @@ non-blocking @code{TryLock} function to allow locking without blocking
execution.")
(license license:bsd-3)))
+(define-public go-github-com-google-renameio
+ (package
+ (name "go-github-com-google-renameio")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/renameio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qn84nra9nxqyqg4i496b6ijbhnxvx66hdndwl7qh7r6q8lz2ba5"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/google/renameio"))
+ (home-page "https://github.com/google/renameio/")
+ (synopsis "Atomically create or replace a file or symbolic link")
+ (description
+ "@code{renameio} Go package provides a way to atomically create or
+replace a file or symbolic link.")
+ (license license:asl2.0)))
+
+(define-public go-github-com-google-renameio-v2
+ (package/inherit go-github-com-google-renameio
+ (name "go-github-com-google-renameio-v2")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/renameio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13vc7p43zz5pmgli4k18b15khxpca1zd8v1ga0ryq7ddyz55fg7i"))))
+ (arguments
+ (list
+ #:import-path "github.com/google/renameio/v2"))))
+
(define-public go-github-com-google-subcommands
(package
(name "go-github-com-google-subcommands")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6cf873d79d..55cff297cf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5544,45 +5544,6 @@ and from termios translations, readCh, reading passwords, etc.")
into URL query parameters.")
(license license:bsd-3))))
-(define-public go-github-com-google-renameio
- (package
- (name "go-github-com-google-renameio")
- (version "1.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/renameio")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qn84nra9nxqyqg4i496b6ijbhnxvx66hdndwl7qh7r6q8lz2ba5"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/google/renameio"))
- (home-page "https://github.com/google/renameio/")
- (synopsis "Atomically create or replace a file or symbolic link")
- (description "@code{renameio} Go package provides a way to atomically
-create or replace a file or symbolic link.")
- (license license:asl2.0)))
-
-(define-public go-github-com-google-renameio-v2
- (package/inherit go-github-com-google-renameio
- (name "go-github-com-google-renameio-v2")
- (version "2.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/renameio")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "13vc7p43zz5pmgli4k18b15khxpca1zd8v1ga0ryq7ddyz55fg7i"))))
- (arguments
- (list
- #:import-path "github.com/google/renameio/v2"))))
-
(define (go-gotest-tools-source version sha256-base32-hash)
(origin
(method git-fetch)