aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-04 17:05:54 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-04 17:36:29 +0800
commit0f5e4777456c6ecf529a4f80f53de993a786016e (patch)
tree7038aec2cfceabf26ce1445c003245ba9fd1fac9
parent6747fc5efc7de6ba2e7f6b664616939d37e89524 (diff)
downloadguix-0f5e4777456c6ecf529a4f80f53de993a786016e.tar.gz
guix-0f5e4777456c6ecf529a4f80f53de993a786016e.zip
gnu: wireshark: Build from git source.
* gnu/packages/networking.scm (wireshark)[source]: Switch to git-fetch. [arguments]<#:configure-flags>: Set -DVCSVERSION_OVERRIDE. Change-Id: I82356c1faea9a6253108dc17334db2464ba38098
-rw-r--r--gnu/packages/networking.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6a742f6e6b..867883b8ba 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1808,11 +1808,13 @@ of the same name.")
(version "4.4.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.wireshark.org/download/src/wireshark-"
- version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/wireshark/wireshark")
+ (commit (string-append "wireshark-" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1v2nflm8rdifc6pwlzn1ciz22wl15zwkqs3r7gjw60kh59brd7ib"))))
+ (base32 "0cc1dqmlc2jqgd6gg407qk0qkg3cjbiafzw8pf2pxhnh7n94fyki"))))
(build-system qt-build-system)
(arguments
(list
@@ -1821,7 +1823,8 @@ of the same name.")
;; fail.
#:qtbase qtbase
#:configure-flags
- #~(list (string-append "-DCMAKE_MODULE_LINKER_FLAGS=-Wl,-rpath=" #$output "/lib"))
+ #~(list (string-append "-DVCSVERSION_OVERRIDE=" #$version)
+ (string-append "-DCMAKE_MODULE_LINKER_FLAGS=-Wl,-rpath=" #$output "/lib"))
#:phases
#~(modify-phases %standard-phases
(replace 'check