aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:37 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:52 +0000
commit0cb10b21b20286d91c4b23de81a256b76bc1c34e (patch)
treed00af650a6c684c6b7b3f6c625a73dbbe8853419
parent096e68b53d0ed55ff342aac6c0f95a3e13bdd01f (diff)
downloadguix-0cb10b21b20286d91c4b23de81a256b76bc1c34e.tar.gz
guix-0cb10b21b20286d91c4b23de81a256b76bc1c34e.zip
gnu: python-amqp: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-amqp): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Remove unneeded field. <#:test-flags>: Ignore failing test. Change-Id: I8fb99db7fbd6c669a929b95829f9db2fea0691a5 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c5fdb9d96f..8449e9cbbb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20228,18 +20228,10 @@ and provides a uniform API regardless of which JSON implementation is used.")
(uri (pypi-uri "amqp" version))
(sha256
(base32 "1qmmffiy48nady7is8529vxcyqbq88v5zgawqr3fk4q8rkz166rc"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv"
- "-c" "/dev/null" ;take control over pytest options
- ;; Integration tests require network connectivity.
- "--ignore" "t/integration")))))))
+ (list ; Integration tests require network connectivity.
+ #:test-flags '(list "--ignore=t/integration")))
(native-inputs (list python-pytest))
(propagated-inputs (list python-vine))
(home-page "https://github.com/celery/py-amqp")