aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2025-02-06 09:42:16 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-02-06 09:47:33 +0100
commit0c9da3dbcb47840089a0213a59c385e780317bb6 (patch)
tree8671de6470c4a8d205b2825fb7640f698933982d
parent519607fae9a035b31ea4a7357f190887954ac0fa (diff)
downloadguix-0c9da3dbcb47840089a0213a59c385e780317bb6.tar.gz
guix-0c9da3dbcb47840089a0213a59c385e780317bb6.zip
gnu: Add emacs-org-pdftools.
* gnu/packages/emacs-xyz.scm (emacs-org-pdftools): New variable. Change-Id: I181f338c16496f537454dad0a5aec21f13a3daf4
-rw-r--r--gnu/packages/emacs-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 10d619b76d..759000184b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6358,6 +6358,41 @@ DocView mode, and revisiting those PDF files later using the same mode will
restore the saved place.")
(license license:gpl3+)))
+(define-public emacs-org-pdftools
+ (let ((revision "0")
+ (commit "4e420233a153a9c4ab3d1a7e1d7d3211c836f0ac"))
+ (package
+ (name "emacs-org-pdftools")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fuxialexander/org-pdftools.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0n8apjqlm7rs66l635szvsvc4qn8m147g07rgkd30a4v4m24mj8x"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'setenv
+ (lambda _
+ (substitute* "org-pdftools.el"
+ ;; Fix a small typo.
+ (("let [(]pdf-isearch-narrow-to-page t[)]")
+ "let ((pdf-isearch-narrow-to-page t))"))
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list emacs-org-noter emacs-pdf-tools))
+ ;(native-inputs (list emacs-log4e emacs-with-simulated-input))
+ (synopsis "Org mode PDF tools (for doc-view, nov.el and pdf-tools)")
+ (description "This package provides org-mode PDF tools (for builtin
+doc-view and for pdf-view), for example to be able to store links to a page
+in a PDF into an org file.")
+ (home-page "https://github.com/fuxialexander/org-pdftools")
+ (license license:gpl3+))))
+
(define-public emacs-sakura-theme
(package
(name "emacs-sakura-theme")