aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 00:18:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:12 +0200
commit0c746edd1daff63703d075afb982738f71669d0c (patch)
tree2d577fb8ac058965fe29ff22b3be1173c62e2846
parent69a322c9d7edfd551ee06b672b087e26cf602cec (diff)
downloadguix-0c746edd1daff63703d075afb982738f71669d0c.tar.gz
guix-0c746edd1daff63703d075afb982738f71669d0c.zip
gnu: Add texlive-fast-diagram.
* gnu/packages/tex.scm (texlive-fast-diagram): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index be11094929..9576f4d539 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17065,6 +17065,26 @@ current font size, so it can be scaled arbitrarily by changing the font
size.")
(license license:lppl1.3c)))
+(define-public texlive-fast-diagram
+ (package
+ (name "texlive-fast-diagram")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/fast-diagram/"
+ "tex/latex/fast-diagram/")
+ (base32
+ "03ygmgh6gnlkn7dwnwyifv946ja6yswm3gdgv7ad39h5s0ay99hy")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/fast-diagram")
+ (synopsis "Easy generation of FAST diagrams")
+ (description
+ "The package provides simple means of producing FAST diagrams, using
+TikZ/PGF tools. FAST diagrams are useful for functional analysis techniques
+in design methods.")
+ (license license:lppl1.3+)))
+
(define-public texlive-gates
(package
(name "texlive-gates")