aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-04-24 11:37:16 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-04-24 11:37:16 -0400
commit0c297b9b70f4efb10b709a32a5e0d0615e850027 (patch)
tree0cfa3d257101b5ee98f6dc54a72fc7466039d7bb
parent9e81b4da2d0626426d8d7b392b1e88caf5eb0161 (diff)
downloadguix-0c297b9b70f4efb10b709a32a5e0d0615e850027.tar.gz
guix-0c297b9b70f4efb10b709a32a5e0d0615e850027.zip
gnu: python-eventlet: Skip two failing tests.
* gnu/packages/python-xyz.scm (python-eventlet)[arguments]: In 'check' phase, skip two more tests which are failing with Python 3.10 and have upstream bug reports.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db71ab6af5..f508dd2e6c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3013,7 +3013,12 @@ standard.")
"-v" "tests/"
"-I" "greendns_test.py"
"-I" "socket_test.py"
- "-e" "test_018b_http_10_keepalive_framing")))))))
+ "-e" "test_018b_http_10_keepalive_framing"
+ ;; The following two tests fail with Python 3.10. See
+ ;; <https://github.com/eventlet/eventlet/issues/730>.
+ "-e" "test_patcher_existing_locks_locked"
+ ;; And see <https://github.com/eventlet/eventlet/issues/739>.
+ "-e" "test_017_ssl_zeroreturnerror")))))))
(home-page "https://eventlet.net")
(synopsis "Concurrent networking library for Python")
(description