aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 22:23:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:10 +0200
commit0b794d0e1cdff1622754bcc3e2ac2077ba543a6b (patch)
treec5d1bb9a0f62379079af441a6fa7052d0981850f
parenta5481f7cef8e710428b334fbe9c4fbcb1ad0a873 (diff)
downloadguix-0b794d0e1cdff1622754bcc3e2ac2077ba543a6b.tar.gz
guix-0b794d0e1cdff1622754bcc3e2ac2077ba543a6b.zip
gnu: Add texlive-ecgdraw.
* gnu/packages/tex.scm (texlive-ecgdraw): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ca16a9975c..19b852089c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16934,6 +16934,33 @@ support.")
LaTeX documents, using the TikZ package.")
(license license:lppl1.3c)))
+(define-public texlive-ecgdraw
+ (package
+ (name "texlive-ecgdraw")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ecgdraw/" "source/latex/ecgdraw/"
+ "tex/latex/ecgdraw/")
+ (base32
+ "16kbmf9fckms0vhi41h2p6k8znv6plzwn4f2j374zmpqphq1m3il")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:tex-format "latex"))
+ (native-inputs
+ (list (texlive-updmap.cfg
+ (list texlive-hypdoc
+ texlive-layaureo
+ texlive-listings
+ texlive-pgf
+ texlive-tools))))
+ (home-page "https://ctan.org/pkg/ecgdraw")
+ (synopsis "Draws electrocardiograms (ECG)")
+ (description
+ "This package provides the @code{\\ECG} command, which draws
+electrocardiograms (ECG). It can generate different types of wave.")
+ (license license:lppl1.3+)))
+
(define-public texlive-gates
(package
(name "texlive-gates")