aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 12:33:28 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:06 +0800
commit0b0e9c9ce617a2df007a728244fe4a2d4fa100cb (patch)
treee7e12a30d9429407c725f3167f4ac6ff6da6bcde
parent5af200dc56e34af07daacd176215d1ba0c43b972 (diff)
downloadguix-0b0e9c9ce617a2df007a728244fe4a2d4fa100cb.tar.gz
guix-0b0e9c9ce617a2df007a728244fe4a2d4fa100cb.zip
gnu: breeze: Update to 6.1.2.
* gnu/packages/kde-plasma.scm (breeze): Update to 6.1.2. [arguments]: Set #:qtbase to qtbase; <#:configure-flags>: Pass -DBUILD_QT5=OFF. [inputs]: Remove kwayland, qtbase-5, qtdeclarative-5, and qtx11extras; add kcolorscheme. Change-Id: Ibe74aa91653547f5e54150ea308ba162dec92399
-rw-r--r--gnu/packages/kde-plasma.scm25
1 files changed, 7 insertions, 18 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 542f4970cb..83b6cf2d0f 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -122,26 +122,16 @@
(define-public breeze
(package
(name "breeze")
- (version "5.27.7")
+ (version "6.1.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1wfclkg4d3wraz19kwpm87vwp9327s5y8n1a42qgrdh980qwzzdz"))))
+ "1kvx8ynb5m66m1zdrfk5bzpjs879sl8m1ap914199i21v58dqmnl"))))
(build-system qt-build-system)
- ;; TODO: Warning at /gnu/store/…-kpackage-5.34.0/…/KF5PackageMacros.cmake:
- ;; warnings during generation of metainfo for org.kde.breezedark.desktop:
- ;; Package type "Plasma/LookAndFeel" not found
- ;; TODO: Check whether is makes sence splitting into several outputs, like
- ;; Debian does:
- ;; - breeze-cursor-theme
- ;; - "out", "devel"
- ;; - kde-style-breeze - Widget style
- ;; - kde-style-breeze-qt4 - propably not useful
- ;; - kwin-style-breeze
- ;; - qml-module-qtquick-controls-styles-breeze - QtQuick style
+ ;; TODO: Check whether is makes sence splitting into several outputs.
(native-inputs
(list extra-cmake-modules pkg-config))
(inputs
@@ -153,13 +143,12 @@
kguiaddons
ki18n
kirigami
- kiconthemes ; for optional kde-frameworkintegration
+ kiconthemes
kpackage
- kwayland ; optional
kwindowsystem
- qtbase-5
- qtdeclarative-5 ; optional
- qtx11extras))
+ kcolorscheme))
+ (arguments (list #:qtbase qtbase
+ #:configure-flags #~(list "-DBUILD_QT5=OFF")))
(home-page "https://invent.kde.org/plasma/breeze")
(synopsis "Default KDE Plasma theme")
(description "Artwork, styles and assets for the Breeze visual style for