aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrigory Shepelev <shegeley@gmail.com>2025-02-27 06:18:29 +0300
committerIan Eure <ian@retrospec.tv>2025-03-01 08:56:02 -0800
commit0afe31a1365e7df6cfae4ba34d9cadd82ac8cce5 (patch)
treece6dd5235c75eb3767a05fb88e8b2c7083b3e95e
parent6ca7b07a251739dfaefa639e74c01e3013c9454c (diff)
downloadguix-0afe31a1365e7df6cfae4ba34d9cadd82ac8cce5.tar.gz
guix-0afe31a1365e7df6cfae4ba34d9cadd82ac8cce5.zip
gnu: Add emacs-flycheck-deno
Change-Id: If447a3bb0135f959c907465fe12f26624fd150eb Signed-off-by: Ian Eure <ian@retrospec.tv>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 272be3a275..e19b77d6e3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9728,6 +9728,30 @@ errors.")
the current Cargo project.")
(license license:gpl3+)))
+(define-public emacs-flycheck-deno
+ (package
+ (name "emacs-flycheck-deno")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/flycheck/flycheck-deno")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vvhzidnpzf25z5qn85zx7cpwaavd22vsds4q9y5mpmf8hi526l6"))))
+ (propagated-inputs
+ (list emacs-flycheck))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/flycheck/flycheck-deno")
+ (synopsis "Deno support for Flycheck")
+ (description
+ "This Flycheck extension configures Flycheck automatically for
+ the current Deno project.")
+ (license license:gpl3+)))
+
(define-public emacs-flycheck-package
(package
(name "emacs-flycheck-package")