aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-18 09:33:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:24 +0100
commit0a7a2b24d390c7acb383fe03817f7b6b318cf91e (patch)
tree97433451f206c9ebb16ab1b95cdb9b9fa6b23972
parentaa0650d159ba9a7aaac6bd29f0279b4d4c4709ad (diff)
downloadguix-0a7a2b24d390c7acb383fe03817f7b6b318cf91e.tar.gz
guix-0a7a2b24d390c7acb383fe03817f7b6b318cf91e.zip
gnu: python-pandas-2: Remove X.
These tests are not run anyway, so there is no need to launch an X server. * gnu/packages/python-science.scm (python-pandas-2)[arguments]: Rename 'prepare-x phase to 'pre-check. [native-inputs]: Remove xorg-server-for-tests. Change-Id: Ib85883360397d2715a1893b74435d96a1d119f9e
-rw-r--r--gnu/packages/python-science.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 718c482037..0606643f99 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1279,10 +1279,8 @@ doing practical, real world data analysis in Python.")
(string-append "__version__ = \""
#$(package-version this-package)
"\""))))))
- (add-before 'check 'prepare-x
+ (add-before 'check 'pre-check
(lambda _
- (system "Xvfb &")
- (setenv "DISPLAY" ":0")
(setenv "HOME" ".")
;; Skip tests that require lots of resources.
(setenv "PANDAS_CI" "1")))
@@ -1328,9 +1326,7 @@ doing practical, real world data analysis in Python.")
python-pytest-localserver
python-pytest-mock
python-pytest-xdist
- python-versioneer
- ;; Needed to test clipboard support.
- xorg-server-for-tests))
+ python-versioneer))
(home-page "https://pandas.pydata.org")
(synopsis "Data structures for data analysis, time series, and statistics")
(description