aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-16 22:00:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:42:13 +0300
commit0a53c7fac04a000f20a3307d4423098db7c0705d (patch)
treeee69d3d450089bd7212d1275c0d32debcd7bc553
parente4e08cfe1286579dbe866cbf57f3182119450e74 (diff)
downloadguix-0a53c7fac04a000f20a3307d4423098db7c0705d.tar.gz
guix-0a53c7fac04a000f20a3307d4423098db7c0705d.zip
gnu: Add rust-force-send-sync-1.
* gnu/packages/crates-io.scm (rust-force-send-sync-1): New variable. Change-Id: I58512d67968cea8b75e95b96a64f7874c3ff4947
-rw-r--r--gnu/packages/crates-io.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 49946d0ed3..f4e019fe34 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24971,6 +24971,23 @@ implementation that is more efficient for smaller hash keys.")
("rust-walkdir" ,rust-walkdir-2)
("rust-winapi" ,rust-winapi-0.3))))))
+(define-public rust-force-send-sync-1
+ (package
+ (name "rust-force-send-sync")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "force-send-sync" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1dpy69psypanm8mx3k0mjmvb0mccyyd8yffcdr1899la8k68ss1j"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/pacman82/force-send-sync")
+ (synopsis "Unsafe wrappers to force Send and Sync")
+ (description "Unsafe wrappers to force Send and Sync.")
+ (license license:expat)))
+
(define-public rust-foreign-types-0.5
(package
(name "rust-foreign-types")