aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 11:55:05 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:44 +0000
commit09e340ea6169a0c0b654515fdabaf9867e44ba5f (patch)
tree9a30410944ab2563ee541a89716ce97607de4b81
parentc0abeb4efa67e8e179c5eebef093cc247ac6ea51 (diff)
downloadguix-09e340ea6169a0c0b654515fdabaf9867e44ba5f.tar.gz
guix-09e340ea6169a0c0b654515fdabaf9867e44ba5f.zip
gnu: Add python-whatthepatch.
* gnu/packages/python-xyz.scm (python-whatthepatch): New variable. Change-Id: If087238003594c55f52d4467b6e7b494a52348f8
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ec29634b63..c218929d0d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20133,6 +20133,24 @@ templates into Python modules.")
server with very acceptable performance.")
(license license:zpl2.1)))
+(define-public python-whatthepatch
+ (package
+ (name "python-whatthepatch")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "whatthepatch" version))
+ (sha256
+ (base32 "024grf30vkpcfr3bq822zv3slhx12ifm51rmfv1inn0j50blqdvz"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/cscorley/whatthepatch")
+ (synopsis "Patch parsing and application library")
+ (description
+ "This package provides a patch parsing and application library.")
+ (license license:expat)))
+
(define-public python-whichcraft
(package
(name "python-whichcraft")