aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-12 23:18:41 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:42 +0000
commit08fc94fa8b7c1f9c561bade2ddc2304711c74e2e (patch)
tree2a94cf6ad54cc6ce5997aca392b595d8e77aeb67
parent9e897dabcab40c4b592a311aab0729e86878d0a5 (diff)
downloadguix-08fc94fa8b7c1f9c561bade2ddc2304711c74e2e.tar.gz
guix-08fc94fa8b7c1f9c561bade2ddc2304711c74e2e.zip
gnu: go-golang-org-x-tools: Update to 0.25.0.
* gnu/packages/golang-build.scm (go-golang-org-x-tools): Update to 0.25.0. [arguments]: <#:phases>: 'check phase disable tests for subdir "go/collgraph", sort alphabetically. [native-inputs]: Add go-github-com-google-go-cmp. Change-Id: I8419f09d283d1332351a0620269ef39e2db32f09
-rw-r--r--gnu/packages/golang-build.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 11978d8524..bb608dc568 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -748,7 +748,7 @@ time.")
(define-public go-golang-org-x-tools
(package
(name "go-golang-org-x-tools")
- (version "0.24.0")
+ (version "0.25.0")
(source
(origin
(method git-fetch)
@@ -757,7 +757,7 @@ time.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "007n9bmhxn2yspvmcdbj8h0l132vhakszv4i0bd65cvravskcw8y"))
+ (base32 "12r0cwsq898vka7jkxwjv1s8y8z2gxzq8z15ssl37y85hhcadkl8"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -784,12 +784,13 @@ time.")
;; - godoc
;; FIXME: Figure out why they are failing:
+ ;; "./go/analysis/..."
+ ;; "./go/callgraph/..."
+ ;; "./go/packages/..."
+ ;; "./go/ssa/..."
;; "./internal/..."
;; "./present/..."
;; "./refactor/eg/..."
- ;; "./go/ssa/..."
- ;; "./go/packages/..."
- ;; "./go/analysis/..."
"./blog/..." ;
"./container/..."
@@ -797,7 +798,6 @@ time.")
"./cover/..."
"./go/ast/..."
"./go/buildutil/..."
- "./go/callgraph/..."
"./go/cfg/..."
"./go/expect/..."
"./go/gccgoexportdata/..."
@@ -812,7 +812,8 @@ time.")
"./refactor/satisfy/..."
"./txtar/..."))))))))
(native-inputs
- (list gccgo-14))
+ (list gccgo-14
+ go-github-com-google-go-cmp))
(propagated-inputs
(list go-github-com-yuin-goldmark
go-golang-org-x-mod