aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 09:24:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:39 +0000
commit08dd8e45062a2b3b5ad34fc92c8c8b10bacbffd9 (patch)
tree455bbaab19ae4fedb43f79c3346104022155fd7b
parent8aa54b9ff6f2cdaace37a3920a9209677c870d11 (diff)
downloadguix-08dd8e45062a2b3b5ad34fc92c8c8b10bacbffd9.tar.gz
guix-08dd8e45062a2b3b5ad34fc92c8c8b10bacbffd9.zip
gnu: python-flake8-bugbear: Update to 24.10.31.
* gnu/packages/python-xyz.scm (python-flake8-bugbear): Update to 24.10.31. Improve style. [source]: Adjust URI name as PyPI archive was changed. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Remove 'disable-test. [native-inputs]: Remove python-hypothesis; add python-pytest, python-setuptools, and python-wheel. [description]: Start from a new line, adjust fill column. Change-Id: Id8580c8b2d20820a9f16ec719d35ac3b1dbf548e
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 14 insertions, 21 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 605085a10e..f193be0a50 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15336,35 +15336,28 @@ blind @code{except:} statements.")
(define-public python-flake8-bugbear
(package
(name "python-flake8-bugbear")
- (version "20.1.4")
+ (version "24.10.31")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "flake8-bugbear" version))
+ (uri (pypi-uri "flake8_bugbear" version))
(sha256
- (base32
- "0qiihb242fygzyrfynq913ak7cdmx8mcac9c0zk3y5gv16qf80mx"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'disable-test
- (lambda _
- ;; This test fails on slow computers.
- (substitute* "tests/test_bugbear.py"
- (("def test_does_not_crash_on_any_valid_code")
- "def _test_does_not_crash_on_any_valid_code")))))))
+ (base32 "1nrrwhfmk49riflmng26qqjzvfang5lij14ripzqwzxjf8f56ns3"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-hypothesis python-hypothesmith))
+ (list python-hypothesmith
+ python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
- (list python-attrs python-flake8))
+ (list python-attrs
+ python-flake8))
(home-page "https://github.com/PyCQA/flake8-bugbear")
- (synopsis
- "Flake8 plugin for finding likely bugs and design problems in your program")
+ (synopsis "Flake8 plugin for finding likely bugs and design problems in your program")
(description
- "This package contains a plugin for Flake8 finding likely bugs and
-design problems in your program. It contains warnings that don't belong
-in pyflakes and pycodestyle.")
+ "This package contains a plugin for Flake8 finding likely bugs and design
+problems in your program. It contains warnings that don't belong in pyflakes
+and pycodestyle.")
(license license:expat)))
(define-public python-flake8-continuation