aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-28 16:40:46 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-14 21:38:03 +0000
commit078849455edf086cc5f17aca1d5fc9a5aeb5dce5 (patch)
tree55dd940b04ecf07d02a99b8d55acaeee41a30e71
parent554bf4f6062713901af01878bce23530fdebed17 (diff)
downloadguix-078849455edf086cc5f17aca1d5fc9a5aeb5dce5.tar.gz
guix-078849455edf086cc5f17aca1d5fc9a5aeb5dce5.zip
gnu: Add ruby-activestorage.
* gnu/packages/rails.scm (ruby-activestorage): New variable.
-rw-r--r--gnu/packages/rails.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index 6bcfe2667d..a45dca65d1 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -306,6 +306,32 @@ applications.")
(home-page "https://rubyonrails.org/")
(license license:expat)))
+(define-public ruby-activestorage
+ (package
+ (name "ruby-activestorage")
+ (version "5.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "activestorage" version))
+ (sha256
+ (base32
+ "0c72837098sw384vk6dmrb2p7q3wx4swnibk6sw9dp4hn1vc4p31"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; No included tests
+ #:tests? #f))
+ (propagated-inputs
+ `(("ruby-actionpack" ,ruby-actionpack)
+ ("ruby-activerecord" ,ruby-activerecord)
+ ("ruby-marcel" ,ruby-marcel)))
+ (synopsis "Integrate file storage services in to Rails applications")
+ (description
+ "ActiveStorage integrates file storage services with Rails applications,
+allowing files to be attached to ActiveRecord models..")
+ (home-page "https://rubyonrails.org/")
+ (license license:expat)))
+
(define-public ruby-actionmailer
(package
(name "ruby-actionmailer")
. Use VERSION to conditionally return old style vs new style initrd arguments. (%boot-parameters-version): Increment to 1. (operating-system-boot-parameters): Adjust doc. (operating-system-boot-parameters-file): Likewise. * gnu/system/linux-initrd.scm (raw-initrd, base-initrd): Likewise. * doc/guix.texi: Adjust doc. * gnu/build/activation.scm (boot-time-system): Adjust accordingly. * gnu/build/hurd-boot.scm (boot-hurd-system): Likewise. * gnu/packages/commencement.scm (%final-inputs-riscv64): Adjust comment. Maxim Cournoyer 2022-02-09Revert kernel modules changes to support the Coreboot framebuffer...These changes broke the creation of the 'linux-modules-database' for all kernel series besides 5.15, 5.4, and 5.10, like this: ------ gnu/build/linux-modules.scm:257:5: kernel module not found "framebuffer_coreboot" "/gnu/store/yff45fr6q93mw44zdql9ffr95zcvwxcn-linux-libre-4.9.299/lib/modules" ------ We should support the coreboot framebuffer, but we need to test that change more completely before deploying it. This effectively reverts the following commits: 1dfe8c372163d481ebebb97dd3b4cafa49906b28 "gnu: linux-libre: Build simplefb into all x86{,_64} kernels." bc09e7ab569d5306ce99c5525150695c9d539ef0 "gnu: linux-libre: Support the Coreboot framebuffer." Fixes <https://issues.guix.gnu.org/52667> "System reconfiguration fails to build linux-modules.drv". Leo Famulari