aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-02-27 09:44:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-02-27 09:59:50 +0100
commit0729d415e69afcd64ef6b01b5891946067e1eb01 (patch)
tree4630f7ced27bc5928dd8e4fbb9485ee1c5a0a33b
parent5ce0fb8048e13e35a58e68a260c88495c2004fc4 (diff)
downloadguix-0729d415e69afcd64ef6b01b5891946067e1eb01.tar.gz
guix-0729d415e69afcd64ef6b01b5891946067e1eb01.zip
gnu: python-pandera: Use Pydantic 2.
* gnu/packages/python-science.scm (python-pandera)[propagated-inputs]: Replace python-pydantic with python-pydantic-2. [arguments]: Disable one test. Change-Id: Ie222a484f4d8a540ffdf6db6da09e600723169d7
-rw-r--r--gnu/packages/python-science.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 481d3fc171..80bd14f8f4 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1637,7 +1637,10 @@ idea of the remaining amount of computation to be done.")
"not test_python_std_list_dict_generics"
" and not test_python_std_list_dict_empty_and_none"
" and not test_pandas_modules_importable"
- " and not test_check_groups"))))
+ " and not test_check_groups"
+ ;; This is a test failure due to unexpected error
+ ;; message format. It is harmless.
+ " and not test_pandas_stubs_false_positives"))))
;; Pandera comes with a lot of extras. We test as many as possible, but do
;; not include all of them in the propagated-inputs. Currently, we have to
;; skip the pyspark and io tests due to missing packages python-pyspark
@@ -1648,7 +1651,7 @@ idea of the remaining amount of computation to be done.")
python-packaging
python-pandas
python-pandas-stubs ;mypy extra
- python-pydantic
+ python-pydantic-2
python-scipy ;hypotheses extra
python-typeguard
python-typing-inspect