aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 12:59:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:48 +0100
commit06e94114a458d0cffdc00e9789320dceb47ac24d (patch)
tree88f1ebd3c28389d28cb0fec986c526faf4f934a9
parent8f70fb90a24096499ecd7077ff9a29497bb4e6cc (diff)
downloadguix-06e94114a458d0cffdc00e9789320dceb47ac24d.tar.gz
guix-06e94114a458d0cffdc00e9789320dceb47ac24d.zip
gnu: go-golang-org-x-exp: Update to 0.0.0-20240613232115-7f521ea00fb8.
* gnu/packages/golang-build.scm (go-golang-org-x-exp): Update to 0.0.0-20240613232115-7f521ea00fb8. Change-Id: I0317b402ec8b5c0cd9b519725b3fdcc07126feac
-rw-r--r--gnu/packages/golang-build.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index b7e7b6f14f..1b966fd94e 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -124,7 +124,7 @@ for the Go language.")
(define-public go-golang-org-x-exp
(package
(name "go-golang-org-x-exp")
- (version "0.0.0-20221004215720-b9f4876ce741")
+ (version "0.0.0-20240613232115-7f521ea00fb8")
(source
(origin
(method git-fetch)
@@ -133,7 +133,20 @@ for the Go language.")
(commit (go-version->git-ref version))))
(file-name (git-file-name name version))
(sha256
- (base32 "030b929xyg8dpp6f4qbyg63msi6zgzj9sqmvnyphfcrjkqf7nr41"))))
+ (base32 "0ccjgv19w5p9sbcq12czmfnkjwv3b7hfljifwax6r9wk4dx0fcn7"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Submodules with their own go.mod files and packed as separated
+ ;; packages:
+ ;;
+ ;; - golang.org/x/exp/event
+ ;; - golang.org/x/exp/jsonrpc2
+ ;; - golang.org/x/exp/shiny
+ ;; - golang.org/x/exp/sumbdb
+ ;; - golang.org/x/exp/typeparams
+ (for-each delete-file-recursively
+ (list "event" "jsonrpc2" "shiny" "sumdb" "typeparams"))))))
(build-system go-build-system)
(arguments
'(#:import-path "golang.org/x/exp"