aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:38:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:09 +0200
commit06cda1cb79acdf548d94297340d6811d85bae79e (patch)
tree2cb4331650c31b76d4a7cdf7856fcb5400fb2a19
parent8cbdc192fce6d12795aa750966063c873e689c4c (diff)
downloadguix-06cda1cb79acdf548d94297340d6811d85bae79e.tar.gz
guix-06cda1cb79acdf548d94297340d6811d85bae79e.zip
gnu: Add texlive-perfectcut.
* gnu/packages/tex.scm (texlive-perfectcut): New variable.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 044b01ed56..33cee1e3d1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5348,6 +5348,35 @@ customized by means of different @code{\\pascal} macro options or the
@code{\\pascalset} macro.")
(license license:lppl1.3c)))
+(define-public texlive-perfectcut
+ (package
+ (name "texlive-perfectcut")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/perfectcut/"
+ "tex/latex/perfectcut/")
+ (base32
+ "13lclcf5aynbivhlsgnssi36dgacmyjl3rmr0i8s3az5941bsyfh")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/perfectcut")
+ (synopsis
+ "Nested delimiters that consistently grow regardless of the contents")
+ (description
+ "This package defines the command @code{\\perfectcut#1#2} which displays
+a bracket @samp{<#1||#2>}. Various other delimiters are similarly
+defined (parentheses, square brackets ...). The effect of these commands is
+to let the delimiters grow according to the number of nested
+@code{\\perfectcommands} (regardless of the size of the contents).
+
+The package was originally intended for solving a notational issue for
+direct-style continuation calculi in proof theory. For general use, the
+package also defines commands for defining other sorts of delimiters which
+will behave in the same way. The package also offers a robust
+reimplementation of @code{\\big}, @code{\\bigg}, etc.")
+ (license license:lppl1.3+)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")