aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Szmulewicz <daniel.szmulewicz@gmail.com>2024-07-14 18:23:33 +0300
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-07-21 09:42:13 +0200
commit05cf5f6d47ba68cea0d22761498755729475a682 (patch)
treeeebf92048cd37b38007308efed7ff2594ced0748
parentb1edf2649e5f8a801a03a69d5c6de074e2504dc8 (diff)
downloadguix-05cf5f6d47ba68cea0d22761498755729475a682.tar.gz
guix-05cf5f6d47ba68cea0d22761498755729475a682.zip
gnu: Add emacs-flycheck-clj-kondo.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-clj-kondo): New variable. Change-Id: Idc97832c7d3ae546152cb9458b07724e154bcb27 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 34deaa1787..348d361221 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2773,6 +2773,32 @@ different tools. It highlights errors and warnings inline in the buffer, and
provides an optional IDE-like error list.")
(license license:gpl3+))) ;+GFDLv1.3+ for the manual
+(define-public emacs-flycheck-clj-kondo
+ (let ((commit "e38c67ba9db1ea1cbe1b61ab39b506c05efdcdbf")
+ (revision "1"))
+ (package
+ (name "emacs-flycheck-clj-kondo")
+ (version (git-version "0.0.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/borkdude/flycheck-clj-kondo.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pxlb8axgmc8cw4id40z576kd041qb1irq8rkjn6xbda585ix58f"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-flycheck))
+ (home-page "https://github.com/borkdude/flycheck-clj-kondo")
+ (synopsis "Add clj-kondo linter to flycheck")
+ (description
+ "This package integrates clj-kondo with Emacs via flycheck. To use it, add to
+your init.el: (require flycheck-clj-kondo) Make sure the clj-kondo binary is on
+your path. For installation instructions, see
+https://github.com/borkdude/clj-kondo.")
+ (license license:gpl3+))))
+
(define-public emacs-fb2-reader
(let ((commit "9836db284749e0cef4c43c2cb5358c82ae9b8589")) ; version bump
(package