aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-02 20:49:27 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:42 +0000
commit05a11989c6c9bd7f066aa6f469f104cdffda18b0 (patch)
tree659e0546ff85dc886f7aa45efa2dad7ac58c0574
parentad9bb4c5bd3f97384a2c2c328856183f4c3b7ec0 (diff)
downloadguix-05a11989c6c9bd7f066aa6f469f104cdffda18b0.tar.gz
guix-05a11989c6c9bd7f066aa6f469f104cdffda18b0.zip
gnu: python-azure-core: Update to 1.32.0.
* gnu/packages/python-web.scm (python-azure-core): Update to 1.32.0. [source]: Adjust URI name as PyPI archive has been changed. [native-inputs]: Remove unzip; add python-setuptools and python-wheel. Change-Id: I08da865f353a16ec107f1a17bf6376a6519bc62e
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8428ce0d32..964d01d702 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8326,13 +8326,13 @@ Python.")
(define-public python-azure-core
(package
(name "python-azure-core")
- (version "1.28.0")
+ (version "1.32.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "azure-core" version ".zip"))
+ (uri (pypi-uri "azure_core" version))
(sha256
- (base32 "1g9nv5pcjkskv37vsjgsm7am81y629flwkghnvd5dphzzikgrvp9"))))
+ (base32 "1r9hqyqr5fxiiai0irr0n98gwgzj5f8y46vc1yci9bidddfw7cr2"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -8369,7 +8369,8 @@ Python.")
python-pytest-aiohttp
python-pytest-asyncio
python-pytest-trio
- unzip))
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/Azure/azure-sdk-for-python")
(synopsis "Microsoft Azure Core library for Python")
(description "This package provides the Microsoft Azure Core library for