aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:25 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:58 +0000
commit0592a5df16bd561088ec445e2f3a94d1dd8139ed (patch)
tree68bc58788a423d52bc715acd022a8b9f682365ae
parentd41e9ce19478143883c2c81d9d1bbac6d4e6760a (diff)
downloadguix-0592a5df16bd561088ec445e2f3a94d1dd8139ed.tar.gz
guix-0592a5df16bd561088ec445e2f3a94d1dd8139ed.zip
gnu: python-cssselect2: Move to pyproject-build-system.
* gnu/packages/python-web.scm (python-cssselect2): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Remove uneeded 'check phase replacement. Change-Id: I0bdcf546d24bd738d5c547c36faa91483408d1ab Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e8d85177bb..5367d132b0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6279,7 +6279,7 @@ in various CSS modules.")
(uri (pypi-uri "cssselect2" version))
(sha256
(base32 "1j2fcr217rsvkipsg6zjq03rl64rxnvb5hqqpx0dv58fhspvkywk"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -6290,11 +6290,7 @@ in various CSS modules.")
(("'pytest-flake8',") "")
(("'pytest-isort',") "")
(("--flake8") "")
- (("--isort") ""))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (lambda _ (invoke "pytest"))))))))
+ (("--isort") "")))))))
(propagated-inputs
(list python-tinycss2))
(native-inputs