aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-13 16:05:59 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:23 +0200
commit0570c7e7d7654f42712bc266eb83ca083e0cea53 (patch)
treee92431f3791bb203e664ff752d273b3d930af38d
parent3d8a838d9115510cce21e97181bea4e05cd9396f (diff)
downloadguix-0570c7e7d7654f42712bc266eb83ca083e0cea53.tar.gz
guix-0570c7e7d7654f42712bc266eb83ca083e0cea53.zip
gnu: git-minimal: Fix cross build.
This is a follow-up to aae7b00d52275619e7676e948bf286d2a1ffbdb2 gnu: git: Remove labels and use gexps. * gnu/packages/version-control.scm (git-minimal)[arguments]: Use #+ to access native-inputs for bash-minimal and bash. Change-Id: I6b4cb18123d6f98bda84726b99531c88542be12d
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 65cefa6e09..3058313f5b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -28,7 +28,7 @@
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2020, 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 John D. Boy <jboy@bius.moe>
-;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020, 2021, 2022, 2023 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
@@ -275,12 +275,12 @@ Python 3.3 and later, rather than on Python 2.")
#:make-flags
#~(list "V=1" ;more verbose compilation
(string-append "SHELL_PATH="
- #$(this-package-native-input "bash-minimal")
+ #+(this-package-native-input "bash-minimal")
"/bin/sh")
;; Tests require a bash with completion support.
(string-append "TEST_SHELL_PATH="
- #$(this-package-native-input "bash")
+ #+(this-package-native-input "bash")
"/bin/bash")
;; By default 'make install' creates hard links for