aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-06 20:09:24 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-06 22:12:14 +0100
commit041cb5351e83cc921ef46bfbf9080115bcf69aa7 (patch)
treec0ca425e8060a38aff05e3ea7371bd522acc6915
parent6e6b1c2ceb595415cc9eff6cda1cea6bea2cd7ac (diff)
downloadguix-041cb5351e83cc921ef46bfbf9080115bcf69aa7.tar.gz
guix-041cb5351e83cc921ef46bfbf9080115bcf69aa7.zip
gnu: Add perl-file-map.
* gnu/packages/perl.scm (perl-file-map): New variable.
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1a0c164de9..acecd892b0 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1154,6 +1154,25 @@ processes can safely access the cache at the same time. It uses a basic LRU
algorithm to keep the most used entries in the cache.")
(license (package-license perl))))
+(define-public perl-file-map
+ (package
+ (name "perl-file-map")
+ (version "0.71")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/L/LE/LEONT/File-Map-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0na78rf31cn4pp9zrywq1iv3r2xchrw3nqljp950v1sfh0rnkqn8"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build perl-test-fatal perl-test-warnings))
+ (propagated-inputs (list perl-sub-exporter-progressive))
+ (home-page "https://metacpan.org/release/File-Map")
+ (synopsis "Method for memory mapping a file")
+ (description "This package provides a way to memory map a file.")
+ (license (package-license perl))))
+
(define-public perl-capture-tiny
(package
(name "perl-capture-tiny")