aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-10 13:10:46 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:08 +0000
commit03df2b0df7c33e02fbe27b5d59fa7cf628f312b2 (patch)
treeff06af1a4146016958a31d96a0add6a91c60c463
parent319ce81999e5bba06d9c137e3847359211aa15ed (diff)
downloadguix-03df2b0df7c33e02fbe27b5d59fa7cf628f312b2.tar.gz
guix-03df2b0df7c33e02fbe27b5d59fa7cf628f312b2.zip
gnu: Add python-rgbxy.
* gnu/packages/python-xyz.scm (python-rgbxy): New variable. Change-Id: I67a1a6ae5a7ccba888fc938e4212937ec37adb85
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b11241362f..9646e30a14 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25517,6 +25517,27 @@ manipulation, or @code{stdout}.")
@end itemize")
(license license:expat)))
+(define-public python-rgbxy
+ (package
+ (name "python-rgbxy")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rgbxy" version))
+ (sha256
+ (base32 "0c3dgm1rf7ih79pgkj7adffn8hlyqh5qah8rbzlq436kz3srk83q"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (home-page "https://github.com/benknight/hue-python-rgb-converter")
+ (synopsis "RGB conversion tool in Python")
+ (description
+ "This packages implements funtionality of RGB/CIE1931 'xy' gammuts
+convertion: Gamut A, B, and C.")
+ (license license:expat)))
+
(define-public python-sure
(package
(name "python-sure")