aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-12-28 21:34:59 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2025-03-02 20:31:40 +0100
commit023fe398b951789fb5b9bb64b9565813afb50630 (patch)
tree4fd8e607d7c6f203d6ec03f27bcd494cea32a530
parentb0e3233f2f7b8c88fd86ff9e077a0e07ceeb29da (diff)
downloadguix-023fe398b951789fb5b9bb64b9565813afb50630.tar.gz
guix-023fe398b951789fb5b9bb64b9565813afb50630.zip
gnu: Add libspelling.
* gnu/packages/gnome.scm (libspelling): New variable. Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 87cad9f8ec..98faf80254 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13670,6 +13670,33 @@ libraries. Applications do not need to be recompiled--or even restarted.")
(("gtk-update-icon-cache") "true")
(("update-desktop-database") "true"))))))))))
+(define-public libspelling
+ (package
+ (name "libspelling")
+ (version "0.4.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/libspelling")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "030s821sb9rsr1ysl79x7id1bsin9idy8z7p85qr9cvw1w3f2s7r"))))
+ (build-system meson-build-system)
+ (inputs (list enchant gtk gtksourceview sysprof))
+ (native-inputs
+ (list gi-docgen
+ gobject-introspection
+ pkg-config
+ vala
+ ;; For testing.
+ aspell aspell-dict-en))
+ (home-page "https://gitlab.gnome.org/GNOME/libspelling/")
+ (synopsis "Spell-checking library for GTK 4")
+ (description "This package provides a spell-checker for
+GtkTextView widgets.")
+ (license license:lgpl2.1+)))
+
(define-public gnome-builder
(package
(name "gnome-builder")