aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2025-01-21 16:06:26 +0100
committerjgart <jgart@dismail.de>2025-02-03 14:07:26 -0500
commit01dd276cdc1df357dba837574b37905e44c13eba (patch)
treeb92a275d7810073c08fc22fb0d8a39206027b493
parentd6c664143f13c42aaa73a86ef1e5515002135824 (diff)
downloadguix-01dd276cdc1df357dba837574b37905e44c13eba.tar.gz
guix-01dd276cdc1df357dba837574b37905e44c13eba.zip
gnu: python-lsp-black: Update to 2.0.0.
* gnu/packages/python-xyz.scm (python-lsp-black): Update to 2.0.0. [arguments]<#:test-flags>: Add failing tests. Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 476d74a915..f2139413a0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3530,7 +3530,7 @@ Unicode-to-LaTeX conversion.")
(define-public python-lsp-black
(package
(name "python-lsp-black")
- (version "1.3.0")
+ (version "2.0.0")
(source
(origin
(method git-fetch)
@@ -3539,8 +3539,16 @@ Unicode-to-LaTeX conversion.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1gwf3vwb01a3l8b75jbn8kyfmn0lva8vpgjnr75vazhm3lsf78fp"))))
+ (base32 "0ilh6nx15kzrp29nkrpx03vx6dw3n7wq65qwv7bg7kcnyiwacplx"))))
(build-system pyproject-build-system)
+ (arguments
+ ;; The python version is too old for these tests to pass properly.
+ (list #:test-flags
+ `'("-k" ,(string-append
+ "not test_pylsp_format_document_syntax_error"
+ " and not test_pylsp_format_range_syntax_error"
+ " and not test_load_config_defaults"
+ " and not test_load_config_with_skip_options"))))
(propagated-inputs
(list python-black python-lsp-server python-tomli))
(native-inputs