aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-18 21:49:52 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:46 +0100
commit01d65dfa0492ddc35328ddba341e51b518675e42 (patch)
tree3c49ac5761a58907b513d0bd32924eb001a0c1cd
parent26df8fe10a3e9c35ae08cbb159a568c6a9ec1a56 (diff)
downloadguix-01d65dfa0492ddc35328ddba341e51b518675e42.tar.gz
guix-01d65dfa0492ddc35328ddba341e51b518675e42.zip
gnu: Add go-github-com-puerkitobio-purell.
* gnu/packages/golang-web.scm (go-github-com-puerkitobio-purell): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ib7dc05b5c4fd554e3ee6a0a5b297bbb1a3daaa4c
-rw-r--r--gnu/packages/golang-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index eb15128a52..1f1a030852 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3403,6 +3403,31 @@ Caching.")
to jQuery to the Go language.")
(license license:bsd-3)))
+(define-public go-github-com-puerkitobio-purell
+ (package
+ (name "go-github-com-puerkitobio-purell")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PuerkitoBio/purell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zv1pkfvnrpv18ji3mgqa1k77h066yz5hvhdr1mxdz19kdjc5l43"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/PuerkitoBio/purell"))
+ (propagated-inputs
+ (list go-golang-org-x-net go-golang-org-x-text))
+ (home-page "https://github.com/PuerkitoBio/purell")
+ (synopsis "Tiny Go library to normalize URLs")
+ (description
+ "This package provides implements a functionality of URL normalizer as
+described in @url{http://tools.ietf.org/html/rfc3986#section-6, RFC 3986}.")
+ (license license:bsd-3)))
+
(define-public go-github-com-quic-go-qpack
(package
(name "go-github-com-quic-go-qpack")