aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-05-09 22:26:06 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-05-10 01:06:22 +0200
commit01a2389a66719b4106321b13c802ad3f84896b4c (patch)
tree4e3fc30c500c120fb1050cd3fcb0367a11dec4a4
parent8272e5e0b77760bb89f01815a89326f59b360c0e (diff)
downloadguix-01a2389a66719b4106321b13c802ad3f84896b4c.tar.gz
guix-01a2389a66719b4106321b13c802ad3f84896b4c.zip
gnu: Rename "libbase" to "android-libbase".
* gnu/packages/android.scm (libbase): Rename to... (android-libbase): ...this.
-rw-r--r--gnu/packages/android.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index bc679a1777..58259c1689 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -169,9 +169,9 @@ interfaces for either writing or reading logs. The log buffers are divided up
in Main, System, Radio and Events sub-logs.")
(license license:asl2.0)))
-(define libbase
+(define android-libbase
(package
- (name "libbase")
+ (name "android-libbase")
(version (android-platform-version))
(source (android-platform-system-core version))
(build-system android-ndk-build-system)
@@ -320,7 +320,7 @@ various Android core host applications.")
(install-file "diagnose_usb.h" (string-append (assoc-ref outputs "out") "/include"))
#t)))))
(inputs
- `(("libbase" ,libbase)
+ `(("android-libbase" ,android-libbase)
("libcutils" ,libcutils)
("android-liblog" ,android-liblog)
("openssl" ,openssl)))
@@ -611,7 +611,7 @@ Android core.")
("android-ext4-utils" ,android-ext4-utils)
("android-f2fs-utils" ,android-f2fs-utils)
("googletest" ,googletest)
- ("libbase" ,libbase)
+ ("android-libbase" ,android-libbase)
("libcutils" ,libcutils)
("android-liblog" ,android-liblog)
("android-libutils" ,android-libutils)
25cbd619402e9a31991f31ec50'>gnu: Add ghc-tasty-lua....Timothy Sample 2019-11-20gnu: Add ghc-tasty-hedgehog....Timothy Sample 2019-11-20gnu: ghc-hedgehog: Update to 1.0.1....Timothy Sample 2019-11-20gnu: ghc-quickcheck-instances: Update to 0.3.22....Timothy Sample 2019-11-20gnu: ghc-tasty-ant-xml: Update to 1.1.6....Timothy Sample 2019-11-20gnu: ghc-hspec-contrib: Update to 0.5.1....Timothy Sample 2019-11-20gnu: ghc-hspec: Update to 2.7.1....Timothy Sample 2019-11-20gnu: ghc-hspec-core: Update to 2.7.1....Timothy Sample 2019-11-20gnu: ghc-tasty-quickcheck: Update to 0.10.1....Timothy Sample 2019-11-20gnu: ghc-tasty-hunit: Update to 0.10.0.2....Timothy Sample 2019-11-20gnu: ghc-tasty-expected-failure: Update to 0.11.1.2....Timothy Sample 2019-11-20gnu: hspec-discover: Update to 2.7.1....Timothy Sample 2019-11-20gnu: ghc-hspec-meta: Update to 2.6.0....Timothy Sample 2019-11-20gnu: ghc-tasty: Update to 1.2.3....Timothy Sample 2019-11-20gnu: ghc-test-framework-quickcheck2: Update to 0.3.0.5....Timothy Sample 2019-11-20gnu: ghc-test-framework: Update Cabal file to r5....Timothy Sample 2019-11-20gnu: ghc-quickcheck: Update to 2.13.2....Timothy Sample 2019-11-20gnu: cabal-doctest: Update to 1.0.8....Timothy Sample 2019-08-31gnu: Move non-compilers out of haskell.scm....Robert Vollmert 2019-08-31gnu: cabal-doctest: Move to haskell-check.scm....Robert Vollmert 2019-08-07gnu: ghc-ansi-terminal: Downgrade to 0.8.0.4....Robert Vollmert 2019-08-07gnu: Remove ghc-parsec, ghc-stm, ghc-text, ghc-xhtml....Robert Vollmert 2019-07-16gnu: ghc-clock-bootstrap: Move and inherit from ghc-clock....Timothy Sample 2019-07-02gnu: Add ghc-hedgehog....Jacob MacDonald