aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-16 18:50:36 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:10 +0000
commit0035c90f222edf851fac3900a4a9ef74b333e71c (patch)
treeaf024ed6f6831fb1fcfd401eab7a52e0c017a019
parentaa31723ce0275a43a84f861e23d9a5cc50a82bf0 (diff)
downloadguix-0035c90f222edf851fac3900a4a9ef74b333e71c.tar.gz
guix-0035c90f222edf851fac3900a4a9ef74b333e71c.zip
gnu: python-filelock: Update to 3.16.1.
* gnu/packages/python-xyz.scm (python-filelock): Update to 3.16.1. [native-inputs]: Add python-hatch-vcs, python-hatchling, python-pytest, python-pytest-asyncio, python-pytest-mock, and python-setuptools-scm. Change-Id: I001b921f9804a3f1e2ba71ffc3ab2cc765e70e9d
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e70503e7a8..3445b24f44 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3527,15 +3527,26 @@ Python's built-in @code{re} module with compatible interfaces.")
(define-public python-filelock
(package
(name "python-filelock")
- (version "3.0.12")
+ (version "3.16.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "filelock" version))
(sha256
(base32
- "0ngzlvb5j8gqs2nxlp2b0jhzii792h66wsn694qm8kqixr225n0q"))))
- (build-system python-build-system)
+ "0d8ljvmsfgriiqf5dqii91gfcpj7cpjrh8fnsvifaiyvspygnjf2"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Break cycle with virtualenv.
+ #:test-flags #~(list "--ignore=tests/test_virtualenv.py")))
+ (native-inputs
+ (list python-hatch-vcs
+ python-hatchling
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-mock
+ python-setuptools-scm))
(home-page "https://github.com/tox-dev/py-filelock")
(synopsis "Platform independent file lock")
(description "@code{filelock} contains a single module implementing