aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages wordnet)
  #:use-module (guix packages)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (gnu packages)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages gcc)
  #:use-module (gnu packages tcl))

(define-public wordnet
  (package
    (name "wordnet")
    (version "3.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "http://wordnetcode.princeton.edu/"
                                 version "/WordNet-" version ".tar.bz2"))
             (sha256
              (base32
               "08pgjvd2vvmqk3h641x63nxp7wqimb9r30889mkyfh2agc62sjbc"))
             (patches (search-patches
                        "wordnet-CVE-2008-2149.patch"
                        "wordnet-CVE-2008-3908-pt1.patch"
                        "wordnet-CVE-2008-3908-pt2.patch"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags (list (string-append "--with-tcl="
                                              (assoc-ref %build-inputs "tcl")
                                              "/lib")
                               (string-append "--with-tk="
                                              (assoc-ref %build-inputs "tk")
                                              "/lib")

                               ;; Provide the `result' field in `Tcl_Interp'.
                               ;; See <https://bugs.gentoo.org/show_bug.cgi?id=452034>.
                               "CFLAGS=-DUSE_INTERP_RESULT -O2")
       #:phases
       (modify-phases %standard-phases
         (add-before 'build 'build-libwn-PIC
           (lambda _
             ;; GNU Dico links libWN.a in its wordnet.so plugin, so it needs
             ;; PIC.
             (invoke "make" "-C" "lib" "CFLAGS=-O2 -g -fPIC"
                     "LDFLAGS=-fPIC")))
         (add-after 'install 'post-install
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out"))
                   (bin (assoc-ref outputs "tk"))
                   (tk  (assoc-ref inputs "tk"))
                   (tkv ,(let ((v (package-version tk)))
                           (string-take v (string-index-right v #\.)))))
               ;; Move `wishwn' and `wnb' to BIN.
               (for-each (lambda (prog)
                           (let ((orig (string-append out "/bin/" prog))
                                 (dst  (string-append bin "/bin/" prog))
                                 (dir  (string-append tk "/lib/tk" tkv)))
                             (mkdir-p (dirname dst))
                             (copy-file orig dst)
                             (delete-file orig)
                             (wrap-program dst
                                           `("TK_LIBRARY" "" = (,dir))
                                           `("PATH" ":" prefix
                                             (,(string-append out
                                                              "/bin"))))))
                         '("wishwn" "wnb"))))))))
    (outputs '("out"
               "tk"))                             ; for the Tcl/Tk GUI

    (inputs (list bash-minimal tk tcl))
    (home-page "https://wordnet.princeton.edu/")
    (synopsis "Lexical database for the English language")
    (description
     "WordNet is a large lexical database of English.  Nouns, verbs,
adjectives and adverbs are grouped into sets of cognitive synonyms (synsets),
each expressing a distinct concept.  Synsets are interlinked by means of
conceptual-semantic and lexical relations.  The resulting network of
meaningfully related words and concepts can be navigated with the browser.
WordNet is also freely and publicly available for download.  WordNet's
structure makes it a useful tool for computational linguistics and natural
language processing.")
    (license x11)))
phase before the 'install one. Tobias Geerinckx-Rice 2023-02-12gnu: papirus-icon-theme: Recursively resolve symlinks....This follows up on commit aed385e18ec7b68a0bc1bb4b173aeadc9cd97245. * gnu/packages/gnome-xyz.scm (papirus-icon-theme)[arguments]: Replace READLINK with CANONICALIZE-PATH to resolve symlink chains. Tobias Geerinckx-Rice 2023-01-29gnu: papirus-icon-theme: Reduce inode consumption....* gnu/packages/gnome-xyz.scm (papirus-icon-theme)[arguments]: Add a new 'halve-inode-consumption phase. Tobias Geerinckx-Rice 2023-01-31gnu: arc-theme: Update to 20221218....* gnu/packages/gnome-xyz.scm (arc-theme): Update to 20221218. [arguments]: Add gtk4 to the list of themes. [inputs]: Add gtk-engines. Signed-off-by: Christopher Baines <mail@cbaines.net> Sughosha 2023-01-31gnu: materia-theme: Update to 20210322....* gnu/packages/gnome-xyz.scm (materia-theme): Update to 20210322. Signed-off-by: Christopher Baines <mail@cbaines.net> Sughosha 2023-01-28gnu: papirus-icon-theme: Update to 20230104....* gnu/packages/gnome-xyz.scm (papirus-icon-theme): Update to 20230104. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Sughosha 2023-01-22gnu: gnome-shell-extension-radio: Update to 20....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-radio): Update to 20. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Sughosha 2023-01-05gnu: Add yaru-theme...* gnu/packages/gnome-xyz (yaru-theme): New variable Signed-off-by: Ludovic Courtès <ludo@gnu.org> florhizome 2022-12-24gnu: gnome-shell-extension-burn-my-windows: Update to 22....* gnu/packages/gnome-xyz (gnome-shell-extension-burn-my-windows): Update to 22. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Sughosha 2022-12-24gnu: gnome-shell-extension-vertical-overview: Update to 10....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-vertical-overview): Update to 10. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Sughosha 2022-12-24gnu: gnome-shell-extension-unite-shell: Update to 69....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-unite-shell): Update to 69. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Sughosha 2022-12-07gnu: gpaste: Update to 42.2....Fixes <https://issues.guix.gnu.org/58191>. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Attila Lendvai 2022-12-07gnu: gpaste: Fix missing @gschemasCompiled@ substitute....* gnu/packages/gnome-xyz.scm (gpaste) [phases] {fix-introspection-install-dir}: Substitute @gschemasCompiled@ placeholder. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Attila Lendvai 2022-11-25gnu: Add portfolio....* gnu/packages/gnome-xyz.scm (portfolio): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> conses 2022-10-22gnu: gnome-shell-extension-blur-my-shell: Update to 44....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-blur-my-shell): Update to 44. [source]: Remove snippet to delete compiled schemas. [arguments]<#:install-plan>: Update accordingly. <#:phases>: Remove ‘cd-src’. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Charles 2022-09-28gnu: Add gnome-shell-extension-unite-shell....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-unite-shell): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Trevor Richards 2022-09-27gnu: gnome-shell-extension-clipboard-indicator: Update to 42....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-clipboard-indicator): Update to 42. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> kiasoc5 2022-09-26gnu: gnome-shell-extension-gsconnect: Update to 50....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-gsconnect): Update to version 50. Update url references to new organization. Eric Bavier 2022-09-18gnu: gnome-shell-extension-noannoyance: Update to 16-1-b759d10f....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance): Update to 16-1-b759d10f. Liliana Marie Prikler 2022-09-18gnu: gnome-shell-extension-burn-my-windows: Update to 21....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-burn-my-windows): Update to 21. Liliana Marie Prikler 2022-09-18gnu: gnome-shell-extension-vertical-overview: Update to 9....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-vertical-overview): Update to 9. Liliana Marie Prikler 2022-09-18gnu: gnome-shell-extension-dash-to-panel: Update to 51....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-panel): Update to 51. Liliana Marie Prikler 2022-09-18gnu: gnome-shell-extension-just-perfection: Update to 22.0....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-just-perfection): Update to 22.0. Liliana Marie Prikler 2022-09-18gnu: gnome-shell-extension-dash-to-dock: Update to 73....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-dock): Update to 73. Liliana Marie Prikler 2022-09-13gnu: gpaste: Update to 42.1....* gnu/packages/gnome-xyz.scm (gpaste): Update to 42.1. [meson]: Delete argument. [phases]{fix-introspection-install-dir}: Use #$output. [native-inputs]: Remove autoconf, automake and libtool. [inputs]: Remove graphene. Add gtk and libadwaita. Sort. * gnu/packages/patches/gpaste-fix-paths.patch: Update patch. Maxim Cournoyer 2022-09-13gnu: arc-theme: Update to 20220405....* gnu/packages/gnome-xyz.scm (arc-theme): Update to 20220405. [native-inputs]: Add python. Maxim Cournoyer