aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020, 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages readline)
  #:use-module (guix licenses)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages perl)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (ice-9 format))

(define (patch-url version seqno)
  (format #f "mirror://gnu/readline/readline-~a-patches/readline~a-~3,'0d"
          version (string-join (string-split version #\.) "") seqno))

(define (readline-patch version seqno sha256-bv)
  "Return the origin of Readline patch SEQNO, with expected hash SHA256-BV"
  (origin
    (method url-fetch)
    (uri (patch-url version seqno))
    (sha256 sha256-bv)))

(define-syntax-rule (patch-series version (seqno hash) ...)
  (list (readline-patch version seqno (base32 hash))
        ...))

(define %patch-series-8.1
  (patch-series
   "8.1"
   (1 "0i4ikdqgcjnb40y2ss3lm09rq56zih5rzma3bib50dk3d1d4cak8")
   (2 "1p15sfx5xg5k4lam12lyd0givk7dfjddqpnb1jdp3c4clray0nz5")))

(define %patch-series-7.0
  (patch-series
   "7.0"
   (1 "0xm3sxvwmss7ddyfb11n6pgcqd1aglnpy15g143vzcf75snb7hcs")
   (2 "0n1dxmqsbjgrfxb1hgk5c6lsraw4ncbnzxlsx7m35nym6lncjiw7")
   (3 "1027kmymniizcy0zbdlrczxfx3clxcdln5yq05q9yzlc6y9slhwy")
   (4 "0r3bbaf12iz8m02z6p3fzww2m365fhn71xmzab2p62gj54s6h9gr")
   (5 "0lxpa4f72y2nsgj6fgrhjk2nmmxvccys6aciwfxwchb5f21rq5fa")))

(define-public readline
  (package
    (name "readline")
    (version (string-append "8.1."
                            (number->string (length %patch-series-8.1))))
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/readline/readline-"
                                  (version-major+minor version) ".tar.gz"))
              (sha256
               (base32
                "00ibp0n9crbwx15k9vvckq5wsipw98b1px8pd8i34chy2gpb9kpq"))
              (patches (append %patch-series-8.1
                               (search-patches "readline-link-ncurses.patch")))
              (patch-flags '("-p0"))))
    (build-system gnu-build-system)
    (propagated-inputs (list ncurses))
    (arguments
     (list #:configure-flags
           #~(list (string-append
                    "LDFLAGS=-Wl,-rpath -Wl,"
                    (dirname (search-input-file %build-inputs
                                                "lib/libncurses.so")))

                   ;; This test does an 'AC_TRY_RUN', which aborts when
                   ;; cross-compiling, so provide the correct answer.
                   #$@(if (%current-target-system)
                          '("bash_cv_wcwidth_broken=no")
                          '())
                   ;; MinGW: ncurses provides the termcap api.
                   #$@(if (target-mingw?)
                          '("bash_cv_termcap_lib=ncurses")
                          '()))

           #:make-flags
           (if (target-mingw?)
               ;; MinGW: termcap in ncurses
               ;; some SIG_* #defined in _POSIX
               #~'("TERMCAP_LIB=-lncurses"
                   "CPPFLAGS=-D_POSIX -D'chown(f,o,g)=0'")
               #~'())))
    (synopsis "Edit command lines while typing, with history support")
    (description
     "The GNU readline library allows users to edit command lines as they
are typed in.  It can maintain a searchable history of previously entered
commands, letting you easily recall, edit and re-enter past commands.  It
features both Emacs-like and vi-like keybindings, making its usage
comfortable for anyone.")
    (license gpl3+)
    (home-page "https://savannah.gnu.org/projects/readline/")))

(define-public readline-7
  (package (inherit readline)
    (name "readline")
    (version (string-append "7.0."
                            (number->string (length %patch-series-7.0))))
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/readline/readline-"
                                  (version-major+minor version) ".tar.gz"))
              (sha256
               (base32
                "0d13sg9ksf982rrrmv5mb6a2p4ys9rvg9r71d6il0vr8hmql63bm"))
              (patches (append
                        %patch-series-7.0
                        (search-patches "readline-link-ncurses.patch")))
              (patch-flags '("-p0"))))))

(define-public readline-6.2
  (package (inherit readline)
    (version "6.2")
    (source (origin (inherit (package-source readline))
              (method url-fetch)
              (uri (string-append "mirror://gnu/readline/readline-"
                                  version ".tar.gz"))
              (patches (search-patches "readline-6.2-CVE-2014-2524.patch"))
              (patch-flags '("-p0"))
              (sha256
               (base32
                "10ckm2bd2rkxhvdmj7nmbsylmihw0abwcsnxf8y27305183rd9kr"))))))

(define-public rlwrap
  (package
    (name "rlwrap")
    (version "0.46.1")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/hanslub42/rlwrap")
             (commit version)))
       (file-name (git-file-name name version))
       (sha256
        (base32 "0shck0hb3jssk5l2pfylxgwrhlkwydj2ld6j7qk2ns2zviymg8n8"))))
    (build-system gnu-build-system)
    (native-inputs
     (list autoconf automake perl))
    (inputs
     (list readline))
    (synopsis "Wrapper to allow the editing of keyboard commands")
    (description
     "Rlwrap is a 'readline wrapper', a small utility that uses the GNU
readline library to allow the editing of keyboard input for any command.  You
should consider rlwrap especially when you need user-defined completion (by way
of completion word lists) and persistent history, or if you want to program
`special effects' using the filter mechanism.")
    (home-page "https://github.com/hanslub42/rlwrap")
    (license gpl2+)))
bbrotli. [arguments]: Add phase to configure using shared libbrotli. [inputs]: Add brotli. Efraim Flashner 2022-11-23gnu: python-py7zr: Update to 0.20.2....* gnu/packages/python-compression.scm (python-py7zr): Update to 0.20.2. [build-system]: Use pyproject-build-system. [propagated-inputs]: Add python-brotli, python-brotlicffi, python-importlib-metadata, python-inflate64, python-psutil, python-pybcj, python-pycryptodomex, and python-pyppmd; remove python-bcj-cffi, python-ppmd-cffi, python-pycryptodome, and python-zstandard. Ricardo Wurmus 2022-11-23gnu: Add python-pybcj....* gnu/packages/python-compression.scm (python-pybcj): New variable. Ricardo Wurmus 2022-11-23gnu: Add python-inflate64....* gnu/packages/python-compression.scm (python-inflate64): New variable. Ricardo Wurmus 2022-11-23gnu: python-multivolumefile: Update to 0.2.3....* gnu/packages/python-compression.scm (python-multivolumefile): Update to 0.2.3. [build-system]: Use pyproject-build-system. [native-inputs]: Remove python-pep517 and python-setuptools; add python-hypothesis. Ricardo Wurmus 2022-11-23gnu: Add python-brotlicffi....* gnu/packages/python-compression.scm (python-brotlicffi): New variable. Ricardo Wurmus 2022-11-23gnu: Add python-pyppmd....* gnu/packages/python-compression.scm (python-pyppmd): New variable. Ricardo Wurmus 2022-11-23gnu: python-zstandard: Update to 0.19.0....* gnu/packages/python-compression.scm (python-zstandard): Update to 0.19.0. [propagated-inputs]: Add python-cffi. Ricardo Wurmus 2022-11-23gnu: python-pyzstd: Update to 0.15.3....* gnu/packages/python-compression.scm (python-pyzstd): Update to 0.15.3. Ricardo Wurmus 2022-11-23gnu: python-ppmd-cffi: Update to 0.5.0....* gnu/packages/python-compression.scm (python-ppmd-cffi): Update to 0.5.0. [native-inputs]: Remove python-setuptools and python-pep517; add python-hypothesis. Ricardo Wurmus 2022-09-07gnu: python-zopfli: Update to 0.2.1....* gnu/packages/python-compression.scm (python-zopfli): Update to 0.2.1. [arguments]: Use pytest in check phase. [native-inputs]: Add PYTHON-PYTEST. Marius Bakke 2022-08-21gnu: python-lzo: Use G-expressions....* gnu/packages/python-compression.scm (python-lzo)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2022-08-21gnu: python-lzo: Update to 1.14....* gnu/packages/python-compression.scm (python-lzo): Update to 1.14. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2022-08-16gnu: python-lz4: Update to 4.0.2....* gnu/packages/python-compression.scm (python-lz4): Update to 4.0.2. [native-inputs]: Remove PYTHON-NOSE. Add PYTHON-PKGCONFIG and PYTHON-PSUTIL. [arguments]: Override check phase. Marius Bakke 2022-05-31gnu: Remove python2-zipp....* gnu/packages/python-compression.scm (python2-zipp): Delete variable. (python2-zipp-bootstrap): Likewise. Maxim Cournoyer 2022-05-31gnu: Remove python2-lzo....* gnu/packages/python-compression.scm (python2-lzo): Delete variable. Maxim Cournoyer 2022-05-31gnu: Remove python2-lzstring....* gnu/packages/python-compression.scm (python2-lzstring): Delete variable. Maxim Cournoyer 2022-05-31gnu: Remove python2-lz4....* gnu/packages/python-compression.scm (python2-lz4): Delete variable. Maxim Cournoyer 2022-01-10gnu: Add python-zopfli....* gnu/packages/python-compression.scm (python-zopfli): New variable. Maxim Cournoyer 2021-12-15gnu: Add python-isal....* gnu/packages/python-compression.scm (python-isal): New variable. Ricardo Wurmus 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-10-14Merge branch 'master' into core-updates-frozenMarius Bakke 2021-10-13gnu: Remove duplicate python-google-brotli package....* gnu/packages/python-compression.scm (python-brotli): Delete duplicate variable. * gnu/packages/compression.scm (python-google-brotli): Redefine as a deprecated-package, with… (python-brotli): …as the canonical variable. * gnu/packages/fonts.scm (font-meera-inimai)[native-inputs]: Adjust accordingly. Tobias Geerinckx-Rice 2021-08-09gnu: Remove python-setuptools-scm/next....* gnu/packages/python-xyz.scm (python-setuptools-scm/next): Remove variable. (python-pikepdf) [native-inputs]: Swap for python-setuptools-scm. * gnu/packages/python-compression.scm (python-multivolumefile, python-bcj-cffi, python-ppmd-cffi, python-p77zr)[native-inputs]: Same. * gnu/packages/pep.scm (python-pep-adapter)[native-inputs]: Same. Efraim Flashner 2021-04-09gnu: Add python-py7zr....* gnu/packages/python-compression.scm (python-py7zr): New variable. Brendan Tildesley 2021-04-09gnu: Add python-bcj-cffi....* gnu/packages/python-compression.scm (python-bcj-cffi): New variable. Brendan Tildesley 2021-04-09gnu: Add python-pyzstd...* gnu/packages/python-compression.scm (python-pyzstd): New variable. Brendan Tildesley 2021-04-09gnu: python-zstandard: Update to 0.15.2....* gnu/packages/python-compression.scm (python-zstandard): Update to 0.15.2. Brendan Tildesley 2021-04-09gnu: Add python-ppmd-cffi....* gnu/packages/python-compression.scm (python-ppmd-cffi): New variable. Brendan Tildesley 2021-04-09gnu: Add python-multivolumefile....* gnu/packages/python-compression.scm (python-multivolumefile): New variable. Brendan Tildesley 2021-03-17gnu: Use PACKAGE/INHERIT in more places....* gnu/packages/algebra.scm (fftwf, fftw-openmpi), gnu/packages/audio.scm (ztoolkit-rsvg), gnu/packages/bioinformatics.scm (python2-dendropy), gnu/packages/boost.scm (boost-with-python2), gnu/packages/check.scm (python2-mock, python2-pytest-mock), gnu/packages/cups.scm (hplip-minimal), gnu/packages/freedesktop.scm (libinput-minimal), gnu/packages/gettext.scm (gnu-gettext), gnu/packages/glib.scm (python2-pygobject), gnu/packages/gnome.scm (gdl-minimal, libsoup-minimal, python2-pyatspi), gnu/packages/groff.scm (groff-minimal), gnu/packages/jami.scm (ffmpeg-jami), gnu/packages/libcanberra.scm (libcanberra/gtk+-2), gnu/packages/lirc.scm (python2-lirc), gnu/packages/llvm.scm (clang-runtime-3.5), gnu/packages/mpi.scm (java-openmpi, openmpi-thread-multiple), gnu/packages/node.scm (libnode), gnu/packages/onc-rpc.scm (libtirpc/hurd), gnu/packages/python-compression.scm (bitshuffle-for-snappy), gnu/packages/python-crypto.scm (python2-pycrypto, python2-cryptography) (python2-cryptography, python2-m2crypto), gnu/packages/python-web.scm (python2-html2text, python2-tornado) (python2-terminado, python2-ndg-httpsclient, python2-websocket-client) (python2-rauth, python2-url, python2-s3transfer), gnu/packages/python-xyz.scm (python2-psutil, python2-serpent) (python2-humanfriendly, python2-empy, python2-parse-type, python2-polib) (python2-jsonschema, python2-pystache, python2-cython, python2-numpydoc) (python2-ipyparallel, python2-traitlets, python2-dbus) (python2-beautifulsoup4, python2-pep517, python2-flake8, python2-llfuse) (python2-tlsh, python-file, python2-notebook, python-jupyter-console-minimal) (python2-contextlib2, python2-promise, python2-anyjson, python2-amqp) (python2-kombu, python2-billiard, python2-celery, python2-whoosh) (python2-jellyfish, python-rope, ptpython-2, python2-binaryornot) (python2-setproctitle, python2-argcomplete, python2-xopen, python2-isort) (python2-radon, python2-rfc6555, python2-activepapers, python2-send2trash) (python2-cloudpickle, python2-reparser), gnu/packages/python.scm (python2-called-python), gnu/packages/qt.scm (python2-sip, python-pyqt-without-qtwebkit, python2-pyqt) (python-qscintilla, python-pyqt+qscintilla), gnu/packages/scanner.scm (sane-backends), gnu/packages/sdl.scm (guile3.0-sdl2), gnu/packages/selinux.scm (checkpolicy, libselinux, libsemanage, secilc) (python-sepolgen, policycoreutils), gnu/packages/serialization.scm (lua5.1-libmpack, lua5.2-libmpack), gnu/packages/simulation.scm (fenics), gnu/packages/statistics.scm (python2-statsmodels), gnu/packages/texinfo.scm (info-reader), gnu/packages/wxwidgets.scm (wxwidgets-gtk2, wxwidgets-gtk2-3.1), gnu/packages/xml.scm (xmlsec-nss), gnu/packages/xorg.scm (uim-gtk, uim-qt), guix/build-system/python.scm (package-with-explicit-python) (strip-python2-variant): Use PACKAGE/INHERIT. Mark H Weaver 2020-11-26gnu: python-brotli: Update to 1.0.9....* gnu/packages/python-compression.scm (python-brotli): Update to 1.0.9. Marius Bakke