aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2021, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rcm)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages perl))

(define-public rcm
  (package
    (name "rcm")
    (version "1.3.5")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://thoughtbot.github.io/rcm/dist/rcm-"
                                  version ".tar.gz"))
              (sha256
               (base32 "0bdyksrd9i3lkmr9kq6dwa0l4g2403vnma5s4j9h8spi4rziwx14"))))
    (build-system gnu-build-system)
    (arguments '(#:phases
                 (modify-phases %standard-phases
                   (add-after 'patch-source-shebangs 'patch-tests
                     (lambda _
                       (substitute* '("test/rcrc-tilde.t"
                                      "test/rcdn-hooks-run-in-order.t"
                                      "test/rcup-hooks-run-in-order.t")
                         (("/bin/sh") (which "sh")))
                       (substitute* "test/rcup-hooks.t"
                         (("/usr/bin/env") (which "env"))))))
                  #:parallel-tests? #f))
    (native-inputs (list perl python-cram))
    (synopsis "Management suite for dotfiles")
    (description "The rcm suite of tools is for managing dotfiles directories.  This is
a directory containing all the @code{.*rc} files in your home directory
(@code{.zshrc}, @code{.vimrc}, and so on). These files have gone by many
names in history, such as “rc files” because they typically end in rc
or “dotfiles” because they begin with a period.  This suite is useful
for committing your rc files to a central repository to share, but it also
scales to a more complex situation such as multiple source directories
shared between computers with some host-specific or task-specific files.")
    (license bsd-3)
    (home-page "https://github.com/thoughtbot/rcm")))
python-xyz.scm Maxim Cournoyer 2022-01-10gnu: python-pandas: Update to 1.3.5....* gnu/packages/python-science.scm (python-pandas): Update to 1.3.5. [phases]{check}: Add a reference to the network accessing tests issue, now reported upstream. Reinstate the excelwriter tests. [propagated-inputs]: Add python-xlsxwriter. [native-inputs]: Remove python-nose. Maxim Cournoyer 2022-01-12gnu: python-scikit-fuzzy: Disable tests....* gnu/packages/python-science.scm (python-scikit-fuzzy)[arguments]: Add #:tests?. Remove #:phases. Marius Bakke 2022-01-12gnu: python-modin: Permit newer versions of pandas....* gnu/packages/python-science.scm (python-modin)[arguments]: Add phase. Marius Bakke 2021-12-22gnu: python-scipy: Update to 1.7.3....* gnu/packages/python-science.scm (python-scipy): Update to 1.7.3. [native-inputs]: Add python-pydata-sphinx-theme, python-sphinx-panels. [arguments]: Add phase to build without python-pythran. Remove trailing #t from phases. * gnu/packages/sphinx.scm (python-pydata-sphinx-theme)[native-inputs]: Remove python-plotly. Efraim Flashner 2021-12-22gnu: python-pingouin: Update to 0.5.0....* gnu/packages/python-science.scm (python-pingouin): Update to 0.5.0. Arun Isaac 2021-12-21Revert "gnu: python-pingouin: Update to 0.5.0."...This reverts commit f2ad33bc3933b710e5beb6592a9a4925b91b199a. python-pingouin after 0.3.12 needs newer versions of all the python science libraries. Efraim Flashner 2021-12-16gnu: python-pyflow: Rename to python2-pyflow....The package was never compatible with Python 3. Not adding a deprecated package variant, because going from Python 3 to Python 2 is a breaking change and it’s unlikely anyone ever used the package anyway (it was likely broken). * gnu/packages/python-science.scm (python-pyflow): Move… (python2-pyflow): …here. [arguments]: Use Python 2. Lars-Dominik Braun 2021-12-13gnu: python-distributed: Update to 2021.11.2....* gnu/packages/python-science.scm (python-distributed): Update to 2021.11.2. [source](snippet): New field. [arguments]: Add versioneer phase. [native-inputs]: Add PYTHON-VERSIONEER. Marius Bakke 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-12-09gnu: python2-scipy: Override native inputs....* gnu/packages/python-science.scm (python2-scipy)[native-inputs]: Override; replace gfortran with gfortran-7; add gcc-7. Ricardo Wurmus 2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-15gnu: python-pingouin: Update to 0.5.0....* gnu/packages/python-science.scm (python-pingouin): Update to 0.5.0. Arun Isaac 2021-11-15gnu: python-scipy: Run tests conditionally....* gnu/packages/python-science.scm (python-scipy)[arguments]: Respect TESTS? in 'CHECK phase. Ricardo Wurmus 2021-10-25gnu: python-pandas: Update to 1.3.4....* gnu/packages/python-science.scm (python-pandas): Update to 1.3.4. Efraim Flashner 2021-10-25gnu: python-pandas: Fix building with pytest-6....* gnu/packages/python-science.scm (python-pandas)[arguments]: In custom 'check phase adjust to not fail tests with missing test data. Efraim Flashner 2021-10-25gnu: python-pandas: Honor #:tests? flag....* gnu/packages/python-science.scm (python-pandas)[arguments]: Adjust custom 'check phase to honor the #:tests? flag. Efraim Flashner 2021-10-12gnu: python-distributed: Update to 2021.09.1....* gnu/packages/python-science.scm (python-distributed): Update to 2021.09.1. [arguments]: Disable failing test test_text. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Felix Gruber 2021-10-12gnu: python-pandas: Update to 1.3.3....* gnu/packages/python-science.scm (python-pandas): Update to 1.3.3. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Felix Gruber 2021-09-29gnu: python2-pandas: Fix build by reverting inherited fields....* gnu/packages/python-science.scm (python2-pandas)[arguments]: Do not inherit field; revert to values at commit c0d43f62232507b441edf28c3f051921dfb04c2a. [propagated-inputs]: Do not inherit. [inputs]: Same. [native-inputs]: Same. Ricardo Wurmus