aboutsummaryrefslogtreecommitdiff
Upstream status: https://marc.info/?l=linux-doc&m=166861669723994&w=2

From 7edb5b278ee383ff9bed525329b2cdbe22317bf2 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Mon, 14 Nov 2022 22:51:11 -0500
Subject: [PATCH] doc: add texinfodocs and infodocs targets

Sphinx supports generating Texinfo sources and Info documentation,
which can be navigated easily and is convenient to search (via the
indexed nodes or anchors, for example).

This change also causes the html output to appear under its own output
sub-directory, which makes it easier to install, since it's clean from
.doctrees or other output formats.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
---
 Documentation/Makefile                     | 13 ++++++++++++-
 Documentation/userspace-api/media/Makefile |  3 ++-
 Makefile                                   |  2 +-
 3 files changed, 15 insertions(+), 3 deletions(-)

diff --git a/Documentation/Makefile b/Documentation/Makefile
index 64d44c1ecad3..bd8dac560633 100644
--- a/Documentation/Makefile
+++ b/Documentation/Makefile
@@ -93,7 +93,16 @@ quiet_cmd_sphinx = SPHINX  $@ --> file://$(abspath $(BUILDDIR)/$3/$4)
 
 htmldocs:
 	@$(srctree)/scripts/sphinx-pre-install --version-check
-	@+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,html,$(var),,$(var)))
+	@+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,html,$(var),html,$(var)))
+
+texinfodocs:
+	@$(srctree)/scripts/sphinx-pre-install --version-check
+	@+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,texinfo,$(var),texinfo,$(var)))
+
+# Note: the 'info' Make target is generated by sphinx itself when
+# running the texinfodocs target define above.
+infodocs: texinfodocs
+	$(MAKE) -C $(BUILDDIR)/texinfo info
 
 linkcheckdocs:
 	@$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,linkcheck,$(var),,$(var)))
@@ -143,6 +152,8 @@ cleandocs:
 dochelp:
 	@echo  ' Linux kernel internal documentation in different formats from ReST:'
 	@echo  '  htmldocs        - HTML'
+	@echo  '  texinfodocs     - Texinfo'
+	@echo  '  infodocs        - Info'
 	@echo  '  latexdocs       - LaTeX'
 	@echo  '  pdfdocs         - PDF'
 	@echo  '  epubdocs        - EPUB'
diff --git a/Documentation/userspace-api/media/Makefile b/Documentation/userspace-api/media/Makefile
index 00922aa7efde..3d8aaf5c253b 100644
--- a/Documentation/userspace-api/media/Makefile
+++ b/Documentation/userspace-api/media/Makefile
@@ -47,10 +47,11 @@ $(BUILDDIR)/lirc.h.rst: ${UAPI}/lirc.h ${PARSER} $(SRC_DIR)/lirc.h.rst.exception
 
 # Media build rules
 
-.PHONY: all html epub xml latex
+.PHONY: all html texinfo epub xml latex
 
 all: $(IMGDOT) $(BUILDDIR) ${TARGETS}
 html: all
+texinfo: all
 epub: all
 xml: all
 latex: $(IMGPDF) all
diff --git a/Makefile b/Makefile
index 58cd4f5e1c3a..b3266c408b6c 100644
--- a/Makefile
+++ b/Makefile
@@ -1785,7 +1785,7 @@ $(help-board-dirs): help-%:
 # Documentation targets
 # ---------------------------------------------------------------------------
 DOC_TARGETS := xmldocs latexdocs pdfdocs htmldocs epubdocs cleandocs \
-	       linkcheckdocs dochelp refcheckdocs
+	       linkcheckdocs dochelp refcheckdocs texinfodocs infodocs
 PHONY += $(DOC_TARGETS)
 $(DOC_TARGETS):
 	$(Q)$(MAKE) $(build)=Documentation $@

base-commit: 81e7cfa3a9eb4ba6993a9c71772fdab21bc5d870
-- 
2.38.1

ault-gnu-imported-modules with %default-gnu-modules. Change-Id: I57fcb0ef5ef418e5bc5f6c8466f2ff1c5ffc7b37 2024-08-31build-systems: gnu: Export %default-gnu-imported-modules and ↵Maxim Cournoyer %default-gnu-modules. Until now users would have to cargo cult or inspect the private %default-modules variable of (guix build-systems gnu) to discover which modules to include when extending the used modules via the #:modules argument. The renaming was automated via the command: $ git grep -l %gnu-build-system-modules | xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i * guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to... (%default-gnu-imported-modules): ... this. (%default-modules): Rename to... (%default-gnu-modules): ... this. Export. (dist-package, gnu-build, gnu-cross-build): Adjust accordingly. Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee 2024-08-28gnu: dds: Add missing header files.Nicolas Goaziou * gnu/packages/game-development.scm (dds)[arguments]<#:phases>: Also install header files. Change-Id: If3db20d8cb3530be16607d9e7c2a671dfff34439 2024-06-24gnu: godot-lts: Improve package style.Nicolas Graves * gnu/packages/game-development.scm (godot-lts): Re-indent and ensure max column length to 79. [arguments]: Use gexp. Change-Id: I0bedb66a4e7e0ebe6242df885f1e687ce3a43ce0 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2024-06-24gnu: godot-lts: Update to 3.5.3.Nicolas Graves * gnu/packages/game-development.scm (godot-lts): Update to 3.5.3. [arguments]<#:scons>: Update to scons-python. Remove argument. <#:phases>: Rename phase 'wrap to 'wrap-ld-path, remove mesa-related comment that seems to be fixed. [inputs]: Replace freetype by freetype-with-brotli. Change-Id: Ia83bc33bd0b944342ba413b46f0963d3f2197bf5 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2024-06-18gnu: flatzebra: Update to 0.2.0.Nicolas Goaziou * gnu/packages/game-development.scm (flatzebra): Update to 0.2.0. [arguments]: Remove phase. [inputs]: Remove SDL-UNION, SDL, SDL-IMAGE and SDL-MIXER. Add SDL2, SDL2-GFX, SDL2-IMAGE, SDL2-MIXER and SDL2-TTF. Change-Id: If37ab1732e2d984ebc9455cf89c5bfbf32ee20c2 2024-06-15gnu: dhewm3: Update to 1.5.3.James Smith * gnu/packages/game-development.scm (dhewm3): Update to 1.5.3. Change-Id: Iaf1b29540f87043ae6ceef9f3860e5c9331dd191 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> 2024-06-15gnu: dhewm3: Use gexps.James Smith * gnu/packages/game-development.scm (dhewm3) [arguments]: Use gexps. Change-Id: I0a9090a30a988adeb177f282066b1aa31ca1a483 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> 2024-06-15gnu: dhewm3: Use git repository.James Smith * gnu/packages/game-development.scm (dhewm3) [source]: Use git repository instead of downloading a tarball from GitHub. Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> 2024-06-12gnu: godot: Update to 4.2.2.Adriel Dumas--Jondeau * gnu/packages/game-development.scm (godot): Update to 4.2.2. Change-Id: I4450c41439435d18b1e1fb727b9d42c683455831 Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2024-06-11gnu: surgescript: Update to 0.6.0.宋文武 * gnu/packages/game-development.scm (surgescript): Update to 0.6.0. Change-Id: Ie976d33f3f2df4ac5c37476fcd9675c122a5783a Signed-off-by: Christopher Baines <mail@cbaines.net> 2024-05-15gnu: slade: Update to 3.2.5a.Efraim Flashner * gnu/packages/game-development.scm (slade): Update to 3.2.5a. [arguments]: Add a configure-flag to build slade.pk3. Change-Id: I739f9d292a685e86acd4d83c1a5de367f884c523 2024-05-14gnu: renpy: Update to 8.3.0.Liliana Marie Prikler * gnu/packages/game-development.scm (python-renpy): Update to 8.3.0. 2024-05-14gnu: python-pygame-sdl2: Update to 2.1.0+renpy8.3.0.Liliana Marie Prikler * gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0+renpy8.3.0. 2024-04-09Merge remote-tracking branch 'savannah/master' into mesa-updatesChristopher Baines Change-Id: Iad185e2ced97067b3dff8fd722435a6c5e2c00e5 2024-04-06gnu: chipmunk: Update to 7.0.3-1.d0239ef.Nicolas Goaziou * gnu/packages/game-development.scm (chipmunk): Update to 7.0.3-1.d0239ef. [source]<snippet>: Remove fix included upstream. Change-Id: Iac849fffc1d9cf3528a4197ddf741d588fc866a5 2024-04-06gnu: ode: Update to 0.16.5.Nicolas Goaziou * gnu/packages/game-development.scm (ode): Update to 0.16.5. Change-Id: I902c05582c2211d2f620970e74af00ba2f9be19c 2024-04-03gnu: godot: Update to 4.2.1.John Kehayias The previous version failed to build after an update to glslang. Godot looks for an include, Types.h, which is no longer included in the built glslang. Use the included glslang (which will match the included vulkan, too) for now. * gnu/packages/game-development.scm (godot): Update to 4.2.1. [source]: In snippet add (preserve) amd-fsr2, clipper2, glslang (for now), and libktx. [arguments]: Comment out "builtin_glslang=no" in #:scons-flags (for now). Change-Id: I8f6c20e3796ea96f2e6a6a167063f10a667bd4c3 2024-02-25gnu: renpy: Update to 8.2.0.Liliana Marie Prikler * gnu/packages/aux-files/renpy/renpy.in (path-to-saves): Honour RENPY_PATH_TO_SAVES. (path_to_logdir, predefined_searchpath): New procedures. * gnu/packages/game-development.scm (python-renpy): Update to 8.2.0. 2024-02-25gnu: python-pygame-sdl2: Update to 2.1.0+renpy8.2.0.Liliana Marie Prikler * gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0+renpy8.2.0. 2024-02-20gnu: python-pygame: Update to 2.5.2.Ricardo Wurmus * gnu/packages/game-development.scm (python-pygame): Update to 2.5.2. Change-Id: I8fc18627b16ff7e7aeeb84fdb2fdb82593e6ddb7 2024-02-19gnu: Add python-pybox2d.Ricardo Wurmus * gnu/packages/game-development.scm (python-pybox2d): New variable. Change-Id: I1468a1f8cf5ce6170d643447001057eec02500fc 2024-02-08Revert update to Renpy 8.2.Liliana Marie Prikler This reverts commits 9d53c236a69786508197c75d42923e8891c9212d, 2bfe8e95ef7d83961b80b6bacedd2c8c84e056bc, and 08ed3ec64ecd571d92d497b2493f5c0225102c99 as a temporary fix to <https://bugs.gnu.org/68982>. 2024-02-05gnu: mbedtls-apache: Rename to mbedtls-lts.Hilton Chain * gnu/packages/tls.scm (mbedtls-apache): Rename package to "mbedtls". Rename variable to… (mbedtls-lts): …this. (mbedtls-apache): Define as deprecated by mbedtls-lts. (mbedtls-for-hiawatha): Adjust accordingly. * doc/guix.texi: Likewise. * gnu/packages/emulators.scm (dolphin-emu,retroarch)[inputs]: Likewise. * gnu/packages/game-development.scm (godot-lts,godot)[inputs]: Likewise. * gnu/packages/hardware.scm (hueplusplus,openrgb)[inputs]: Likewise. * gnu/packages/haxe.scm (neko,haxe,hashlink)[inputs]: Likewise. * gnu/packages/irc.scm (inspircd)[inputs]: Likewise. * gnu/packages/julia-jll.scm (julia-mbedtls-jll)[arguments]<#:phases>,[inputs]: Likewise. * gnu/packages/julia.scm (julia)[arguments]<#:phases>,[inputs]: Likewise. * gnu/packages/linphone.scm (bctoolbox)[inputs]: Likewise. * gnu/packages/linux.scm (dislocker)[inputs]: Likewise. * gnu/packages/networking.scm (nng)[inputs]: Likewise. * gnu/packages/search.scm (dataparksearch)[inputs]: Likewise. * gnu/packages/video.scm (obs)[inputs]: Likewise. * gnu/packages/web.scm (hiawatha)[arguments]<#:phases>: Likewise. Change-Id: I0c58b3cd0bcf6e44e7b16a69f6d2739aa3c1545b 2024-02-03gnu: raylib: Update to 5.0.Juliana Sims * gnu/packages/game-development.scm (raylib): Update to 5.0. Change-Id: If3797a5f88bdd7f72d47f7f83556e16b319a38f9 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> 2024-01-28gnu: renpy: Fix hashes.Liliana Marie Prikler * gnu/packages/game-development.scm (python-pygame-sdl2, python-renpy): Redownload sources from upstream and use the provided hashes. Fixes: Broken hashes for Ren'py <https://bugs.gnu.org/68644#20> 2024-01-28gnu: python-renpy: Update to 8.2.0.Liliana Marie Prikler * gnu/packages/game-development.scm (python-renpy): Update to 8.2.0. 2024-01-28gnu: python-pygame-sdl2: Update to 2.1.0+renpy8.2.0.Liliana Marie Prikler * gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0+renpy8.2.0. 2024-01-07gnu: dds: Update to 2.9.0-1.d2bc4c2.Nicolas Goaziou * gnu/packages/game-development.scm (dds): Update to 2.9.0-1.d2bc4c2. Change-Id: I3c6db4e81d70112f020f2d7a0f7db26069c7591f Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> 2024-01-07gnu: bbcsdl: Update to 1.39a.宋文武 * gnu/packages/game-development.scm (bbcsdl): Update to 1.39a. [arguments]: Replace bundled "DejaVuSans-Oblique.ttf" with symlink in the 'install' phase. Change-Id: I7b7c8ec8a8216812e1c7a1fab74695b14f4d3ca2 2023-12-31gnu: Add informlib.Adam Faiz * gnu/packages/game-development.scm (informlib): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> 2023-12-31gnu: Add inform.Adam Faiz * gnu/packages/game-development.scm (inform): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> 2023-12-17gnu: python-renpy: Update to 8.1.3.Liliana Marie Prikler * gnu/packages/game-development.scm (python-renpy): Update to 8.1.3. Change-Id: I5e265cdc0f83eda9ae19a3627fa8cd69ef103806 2023-12-17gnu: python-pygame-sdl2: Update to 2.1.0+renpy8.1.3.Liliana Marie Prikler * gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0+renpy8.1.3. Change-Id: Ide0baef4762b2c4174d10e07ec94427916ac41af 2023-12-10gnu: openmw: Update to 0.48.0.Rodion Goritskov * gnu/packages/game-development.scm (openmw): Update to 0.48.0. * gnu/packages/graphics.scm (openmw-openscenegraph): Update to commit 68c5c5. Change-Id: I5e1ae0d59ead8de7976714cb82e8d514c308f19a Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2023-11-23gnu: godot: Update to 4.1.3.Adriel Dumas--Jondeau * gnu/packages/game-development.scm (godot): Update to 4.1.3. Change-Id: Ia8844da04b568e32e9138b222ddfdca7868b010f Signed-off-by: Christopher Baines <mail@cbaines.net> 2023-10-28gnu: godot: Update to 4.1.2.John Kehayias * gnu/packages/game-development.scm (godot): Update to 4.1.2. Change-Id: I358305245305c2cf31e40ce1d33f28c97c224b52 2023-10-03gnu: openvr: Update to 1.26.7.John Kehayias * gnu/packages/game-development.scm (openvr): Update to 1.26.7.