aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages orpheus)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages mp3)
  #:use-module (gnu packages base)
  #:use-module (gnu packages xiph)
  #:use-module (gnu packages xml)
  #:use-module (ice-9 match))

(define-public orpheus
  (package
    (name "orpheus")
    (version "1.6")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "http://thekonst.net/download/orpheus-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1xbgxq8fybwhm51nw9hvvrgi873qzkc2qvmy15d2m2hw2yqa99hq"))
      (patches (search-patches "orpheus-cast-errors-and-includes.patch"))))
    (build-system gnu-build-system)
    (inputs
     (list ncurses
           libvorbis
           vorbis-tools
           mpg321
           ;; TODO: add ghttp
           libxml2
           which))
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (replace 'configure
           (lambda* (#:key outputs #:allow-other-keys)
             ;; This old `configure' script does not support variables passed as
             ;; arguments.
             (let ((out (assoc-ref outputs "out")))
               (setenv "CONFIG_SHELL" (which "bash"))
               (setenv "SHELL" (which "bash"))
               (setenv "LIBS" "-logg")     ;doesn't declare its use of libogg
               (invoke "./configure"
                       (string-append "--prefix=" out)
                       ,@(match (%current-system)
                                ("mips64el-linux"
                                 '("--host=mips64el-unknown-linux-gnu"))
                                ("aarch64-linux"
                                 '("--build=aarch64-unknown-linux-gnu"))
                                (_ `()))))))
         (add-after 'configure 'configure-players
           (lambda* (#:key inputs #:allow-other-keys)
             ;; To avoid propagating the mpg321 and vorbis-tools inputs, we can
             ;; make the orpheus application execute the needed players from the
             ;; store.
             (let ((ogg123 (search-input-file inputs "/bin/ogg123"))
                   (mpg321 (search-input-file inputs "/bin/mpg321"))
                   (which  (search-input-file inputs "/bin/which")))
               (substitute* "src/orpheusconf.cc"
                 (("ogg123") ogg123)
                 (("which")  which)
                 (("mpg321") mpg321))
               #t)))
         (add-before 'build 'patch-shells
           (lambda _
             (substitute* '("src/mp3track.cc"
                            "src/streamtrack.cc"
                            "src/oggtrack.cc")
               (("/bin/sh") (which "sh")))
             #t)))))
    (home-page "http://thekonst.net/en/orpheus")
    (synopsis "Text-mode audio player")
    (description
     "Orpheus is a light-weight text mode menu- and window-driven audio player
application for CDs, internet stream broadcasts, and files in MP3 and Vorbis
OGG format.")
    (license gpl2+)))
odot): Update to 4.3. [source]: Update snippet to preserve "ufbx". [arguments]<#:phases>: In scons-use-env phase change "env_base" to "env" to reflect upstream renaming. Change-Id: I479749a1b2f2acaa48f573d8e5edbb7b15f3797c John Kehayias 2024-09-02gnu: python-xsge: Update to 2021.10.11....* gnu/packages/game-development.scm (python-xsge): Update to 2021.10.11. [native-inputs]: Remove unzip. Change-Id: I2fd9530b61691adf5bb7c7b17c2060bf06d14c86 宋文武 2024-09-02gnu: python-sge: Update to 2.0.2....* gnu/packages/game-development.scm (python-sge): Update to 2.0.2. Change-Id: I7a0d1a64146368dd60fa665c44af79b8161eb29e 宋文武 2024-08-31gnu: game-development: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/game-development.scm (godot-lts)[inputs]: Add 'bash-minimal'. (godot)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Ie92d21eb3b788ce0eff68548e11a8952b77e0e7b Maxime Devos 2024-08-31gnu: tsukundere: Import the correct set of modules....* gnu/packages/game-development.scm (tsukundere) [arguments] <modules>: Replace %default-gnu-imported-modules with %default-gnu-modules. Change-Id: I57fcb0ef5ef418e5bc5f6c8466f2ff1c5ffc7b37 Maxim Cournoyer 2024-08-31build-systems: gnu: Export %default-gnu-imported-modules and %default-gnu-mod......Until now users would have to cargo cult or inspect the private %default-modules variable of (guix build-systems gnu) to discover which modules to include when extending the used modules via the #:modules argument. The renaming was automated via the command: $ git grep -l %gnu-build-system-modules | xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i * guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to... (%default-gnu-imported-modules): ... this. (%default-modules): Rename to... (%default-gnu-modules): ... this. Export. (dist-package, gnu-build, gnu-cross-build): Adjust accordingly. Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee Maxim Cournoyer 2024-08-28gnu: dds: Add missing header files....* gnu/packages/game-development.scm (dds)[arguments]<#:phases>: Also install header files. Change-Id: If3db20d8cb3530be16607d9e7c2a671dfff34439 Nicolas Goaziou 2024-06-24gnu: godot-lts: Improve package style....* gnu/packages/game-development.scm (godot-lts): Re-indent and ensure max column length to 79. [arguments]: Use gexp. Change-Id: I0bedb66a4e7e0ebe6242df885f1e687ce3a43ce0 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Nicolas Graves 2024-06-24gnu: godot-lts: Update to 3.5.3....* gnu/packages/game-development.scm (godot-lts): Update to 3.5.3. [arguments]<#:scons>: Update to scons-python. Remove argument. <#:phases>: Rename phase 'wrap to 'wrap-ld-path, remove mesa-related comment that seems to be fixed. [inputs]: Replace freetype by freetype-with-brotli. Change-Id: Ia83bc33bd0b944342ba413b46f0963d3f2197bf5 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Nicolas Graves 2024-06-18gnu: flatzebra: Update to 0.2.0....* gnu/packages/game-development.scm (flatzebra): Update to 0.2.0. [arguments]: Remove phase. [inputs]: Remove SDL-UNION, SDL, SDL-IMAGE and SDL-MIXER. Add SDL2, SDL2-GFX, SDL2-IMAGE, SDL2-MIXER and SDL2-TTF. Change-Id: If37ab1732e2d984ebc9455cf89c5bfbf32ee20c2 Nicolas Goaziou 2024-06-15gnu: dhewm3: Update to 1.5.3....* gnu/packages/game-development.scm (dhewm3): Update to 1.5.3. Change-Id: Iaf1b29540f87043ae6ceef9f3860e5c9331dd191 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> James Smith 2024-06-15gnu: dhewm3: Use gexps....* gnu/packages/game-development.scm (dhewm3) [arguments]: Use gexps. Change-Id: I0a9090a30a988adeb177f282066b1aa31ca1a483 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> James Smith 2024-06-15gnu: dhewm3: Use git repository....* gnu/packages/game-development.scm (dhewm3) [source]: Use git repository instead of downloading a tarball from GitHub. Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> James Smith 2024-06-12gnu: godot: Update to 4.2.2....* gnu/packages/game-development.scm (godot): Update to 4.2.2. Change-Id: I4450c41439435d18b1e1fb727b9d42c683455831 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Adriel Dumas--Jondeau 2024-06-11gnu: surgescript: Update to 0.6.0....* gnu/packages/game-development.scm (surgescript): Update to 0.6.0. Change-Id: Ie976d33f3f2df4ac5c37476fcd9675c122a5783a Signed-off-by: Christopher Baines <mail@cbaines.net> 宋文武 2024-05-15gnu: slade: Update to 3.2.5a....* gnu/packages/game-development.scm (slade): Update to 3.2.5a. [arguments]: Add a configure-flag to build slade.pk3. Change-Id: I739f9d292a685e86acd4d83c1a5de367f884c523 Efraim Flashner 2024-05-14gnu: renpy: Update to 8.3.0....* gnu/packages/game-development.scm (python-renpy): Update to 8.3.0. Liliana Marie Prikler 2024-05-14gnu: python-pygame-sdl2: Update to 2.1.0+renpy8.3.0....* gnu/packages/game-development.scm (python-pygame-sdl2): Update to 2.1.0+renpy8.3.0. Liliana Marie Prikler