aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages jose)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (guix build-system meson)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages web)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages tls))

(define-public jose
  (package
    (name "jose")
    (version "11")
    (source (origin
              (method url-fetch)
              (uri
               (string-append "https://github.com/latchset/jose/releases/"
                              "download/v" version "/jose-" version ".tar.xz"))
              (sha256
               (base32
                "09c2kn9cjqkgx4g0rf6c2k3ng9970r468c9z7067j8kyf7ksywp2"))))
    (build-system meson-build-system)
    (native-inputs (list pkg-config))
    (inputs (list jansson zlib openssl))
    (home-page "https://github.com/latchset/jose")
    (synopsis "Object Signing and Encryption")
    (description "C-language implementation of Javascript Object Signing and
Encryption")
    (license license:asl2.0)))
-jumbo-with-gcc-11.patch: New file. * gnu/local.mk (dist_PATCH_DATA): Register it. * gnu/packages/password-utils.scm (john-the-ripper-jumbo)[source]: Use it. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net> Jakob Kirsch 2023-07-22gnu: tessen: Update to 2.2.1....* gnu/packages/password-utils.scm (tessen): Update to 2.2.1. [arguments]<#:make-flags>: Set DESTDIR. [license]: License has been changed to GPL2-only. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Hilton Chain 2023-07-16gnu: yapet: Fix documentation directory....* gnu/packages/password-utils.scm (yapet)[arguments]: Add missing stroke. Tobias Geerinckx-Rice 2023-07-16gnu: yapet: Update to 2.6....* gnu/packages/password-utils.scm (yapet): Update to 2.6. Tobias Geerinckx-Rice 2023-07-16gnu: passwdqc: Update to 2.0.3....* gnu/packages/password-utils.scm (passwdqc): Update to 2.0.3. Tobias Geerinckx-Rice 2023-07-16gnu: otpclient: Update to 3.1.9....* gnu/packages/password-utils.scm (otpclient): Update to 3.1.9. Tobias Geerinckx-Rice 2023-07-16gnu: hydra: Update to 9.5....* gnu/packages/password-utils.scm (hydra): Update to 9.5. Tobias Geerinckx-Rice 2023-07-11gnu: keepassxc: Fix broken home-page url....* gnu/packages/password-utils.scm (keepassxc): Fix broken url. [home-page]: Fix broken url. jgart 2023-07-05gnu: Add passwdqc....* gnu/packages/password-utils.scm (passwdqc): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> flabbergasted 2023-07-01gnu: password-store: Fix program name in usage and tmpdir....* gnu/packages/password-utils.scm (password-store): Fix program name in usage and tmpdir. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Tobias Kortkamp 2023-06-14gnu: browserpass-native: Use new package style....* gnu/packages/password-utils.scm (browserpass-native)[arguments]: Use gexps. Drop trailing #t from phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2023-06-14gnu: browserpass-native: Update to 3.1.0....* gnu/packages/password-utils.scm (browserpass-native): Update to 3.1.0. [inputs]: Add bash-minimal. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2023-06-11gnu: Add otpclient....* gnu/packages/password-utils.scm (otpclient): New variable. Liliana Marie Prikler 2023-06-04gnu: keepassxc: Update to 2.7.5....* gnu/packages/password-utils.scm (keepassxc): Update to 2.7.5. Efraim Flashner 2023-03-21gnu: ssh-to-age: Update to 1.1.2....* gnu/packages/password-utils.scm (ssh-to-age): Update to 1.1.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jack Hill 2023-03-21gnu: pass-age: Update to 1.7.4a1....* gnu/packages/password-utils.scm (pass-age): Update to 1.7.4a1. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jack Hill 2023-01-12gnu: Add hydra....* gnu/packages/password-utils.scm (hydra): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Petr Hodina 2023-01-10gnu: keepassxc: Enable wayland support....* gnu/packages/password-utils.scm (keepassxc)[inputs]: Add qtwayland-5. Jonathan Brielmaier