aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2017 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages gperf)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public gperf
  (package
    (name "gperf")
    (version "3.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/gperf/gperf-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq"))))
    (build-system gnu-build-system)
    (arguments '(#:parallel-tests? #f))
    (home-page "https://www.gnu.org/software/gperf/")
    (synopsis "Perfect hash function generator")
    (description
     "gperf is a perfect hash function generator.  For a given list of
strings, it produces a hash function and hash table in C or C++ code.  That
the hash function is perfect means that no collisions can exist and that
look-ups can be made by single string comparisons.")
    (license gpl3+)))

(define-public gperf-3.0
  ;; This older version would use 'unsigned int' in its generated lookup
  ;; functions whereas 3.1 uses 'size_t', which causes breakage such as
  ;; <https://github.com/wingo/elogind/issues/8>.
  (package
    (inherit gperf)
    (version "3.0.4")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gperf/gperf-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn"))))))
>Efraim Flashner 2024-09-05gnu: gtk: Disable failing tests on aarch64....* gnu/packages/gtk.scm (gtk): Disable failing tests on aarch64. Change-Id: Ia950b25fa2141daff0a01a69d9dfb551e26116ea Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Roman Scherer 2024-08-31gnu: gtk: Update to 4.14.5....Cherry picked from gnome-team 7dece4d20617d11284f280f8b7299c24a2305493. A test failed after merging core-updates into master, though it passed previously on both branches. It is unclear what has changed to make it fail. The test is "4941/5465 gtk:gtk / notify" and fails with stderr: MESA: error: ZINK: failed to choose pdev libEGL warning: egl: failed to create dri2 screen MESA: error: ZINK: failed to choose pdev glx: failed to create drisw screen (test program exited with status code -5) This newer version builds and passes all tests. * gnu/packages/gtk.scm (gtk): Update to 4.14.5. Signed-off-by: John Kehayias <john.kehayias@protonmail.com> Change-Id: I6150b2df469358eb0e328f077a9c09a4c2259703 Liliana Marie Prikler 2024-08-31gnu: at-spi2-core: Remove unnecessary test timeout....Guix provides its own superior-quality time-outs. * gnu/packages/gtk.scm (at-spi2-core)[arguments]: Remove the ‘timeout’ argument from the test invocation. Change-Id: Ic324c5992d48cafa4b6b9856b381d461083d8de2 Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Nikola 2024-08-31gnu: at-spi2-core: Honor the #:tests? flag....* gnu/packages/gtk.scm (at-spi2-core)[arguments]: Adjust the 'check phase to honor the #:tests? flag. Skip the tests when building for powerpc-linux. Change-Id: Ia1fc275ebca5d69b851b566ae7afb47fdad8f066 Efraim Flashner 2024-08-31gnu: cairo: Remove labels and use gexps....* gnu/packages/gtk.scm (cairo) [arguments] <configure-flags>: Use gexps. [native-inputs, inputs]: Remove labels. Change-Id: Ifc4d9435bc1e203ee4427452ad26dedbac2de9fc Maxim Cournoyer 2024-08-31gnu: perl-gtk3: Remove input labels....* gnu/packages/gtk.scm (perl-gtk3) [native-inputs]: Remove input labels. Change-Id: Iaf289d8610df9658b83008c898781822a3cd462e Maxim Cournoyer 2024-08-31gnu: goocanvas: Remove input labels....* gnu/packages/gtk.scm (goocanvas) [native-inputs]: Remove input labels. [phases]: Remove trailing #t. Change-Id: I0eca2aeb1e01b81e89a0777fb806539d8a76972b Maxim Cournoyer 2024-08-31gnu: gtkmm: Remove input labels....* gnu/packages/gtk.scm (gtkmm) [native-inputs]: Remove input labels. Change-Id: I7dad8ada8d32c25845877aba0fc68245ff001a7e Maxim Cournoyer 2024-08-31gnu: atkmm: Remove input labels....* gnu/packages/gtk.scm (atkmm) [native-inputs]: Remove input labels. Change-Id: I7dad8ada8d32c25845877aba0fc68245ff001a7e Maxim Cournoyer 2024-08-31gnu: gtkmm-3: Update to 3.24.8....* gnu/packages/gtk.scm (gtkmm-3): Update to 3.24.8. [propagated-inputs]: Remove labels. Change-Id: I5cda1f2a3c211f766c649e23a33f48c277c615d8 Maxim Cournoyer 2024-08-31gnu: gtk-doc: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/gtk.scm (gtk-doc)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I5db498ba4c7c7db239adb2b46a16585da044fd02 Maxime Devos 2024-08-31gnu: gtk-doc: Remove leftovers....No longer needed, package passes tests without these parameters. * gnu/packages/gtk.scm (gtk-doc)[arguments]<#:parallel-tests?>: Re-enable. <#:phases>: Remove 'disable-failing-tests. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2024-08-31gnu: gtk-doc: Wrap XML_CATALOG_FILES....Prefer XML catalog resolution over substitutions on XML files. * gnu/packages/gtk.scm (gtk-doc)[arguments]<#:phases>: Remove 'patch-gtk-doc-scan. Wrap XML_CATALOG_FILES within 'wrap-executables. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2024-08-31gnu: gtk-doc: Rewrite with G-Expressions....* gnu/packages/gtk.scm (gtk-doc): Rewrite with G-Expressions. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2024-08-31gnu: gtk: Drop docbook workaround....* gnu/packages/gtk.scm (gtk)[arguments]<#:phases>: Drop docbook workaround. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2024-08-31gnu: gtk-doc: Add libxslt native-search-paths to its own....Grepping through the built package, gtk-doc invokes 'xsltproc' so we add %libxslt-search-paths to native-search-paths in order for 'xsltproc' to find the XML/SGML catalog files. * gnu/packages/gtk.scm (gtk-doc)[native-search-paths]: Add %libxslt-search-paths. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2024-08-25gnu: Drop gobject-introspection 1.73.1....The actual gobject-introspection has been newer than its "next" variant for some while. * gnu/packages/glib.scm (gobject-introspection-next): Remove variable. * gnu/packages/gtk.scm (gtksourceview)[native-inputs]: Replace gobject-introspection-next with gobject-introspection. * gnu/packages/guile-xyz.scm (guile-g-golf)[native-inputs]: Likewise. Liliana Marie Prikler 2024-08-18Revert "gnu: at-spi2-core: Remove unnecessary test timeout."...This reverts commit 58a839273d1e4fac2b3a0ec456aabdf82deaa124. Hello I am new here: <cbaines>nckx, 58a839273d1e4fac2b3a0ec456aabdf82deaa124 leads to nearly 4000 rebuilds Tobias Geerinckx-Rice 2024-08-18gnu: at-spi2-core: Remove unnecessary test timeout....Guix provides its own superior-quality time-outs. * gnu/packages/gtk.scm (at-spi2-core)[arguments]: Remove the ‘timeout’ argument from the test invocation. Change-Id: Ic324c5992d48cafa4b6b9856b381d461083d8de2 Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Nikola 2024-07-31gnu: gtk-layer-shell: Update to 0.8.0....* gnu/packages/gtk.scm (gtk-layer-shell): Update to 0.8.0. [native-inputs]: Add vala. Change-Id: Iadf1a502eaac3f5f82ed0624c4e8b80d96e5cea0 Danny Milosavljevic 2024-07-26gnu: gtk: Fix build on aarch64....* gnu/packages/gtk.scm (gtk)[arguments]<#:test-options>: Rename failing test suite to match upstream change on aarch64-linux. Change-Id: Ibdf03a94e71f72283a093cba6d5a328004defa5c Co-authored-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2024-07-07gnu: webp-pixbuf-loader: Update to 0.2.4....* gnu/packages/gtk.scm (webp-pixbuf-loader): Update to 0.2.4. Liliana Marie Prikler 2024-06-24gnu: volctl: Update to 0.9.4....* gnu/packages/gtk.scm (volctl): Update to 0.9.4. Change-Id: I70e85592405d574b692398e6d71d235219fb6fe9 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sergiu Ivanov 2024-06-03gnu: gtk: Fix build on i686-linux....* gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section dedicated to failures on i686-linux. Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Liliana Marie Prikler 2024-06-03gnu: gtk: Update to 4.14.2....* gnu/packages/gtk.scm (gtk): Update to 4.14.2. [#:phases]<patch>: Disable new test failures. [inputs]: Add shaderc. Liliana Marie Prikler 2024-06-03gnu: gtkmm@3: Update to 3.24.9....* gnu/packages/gtk.scm (gtkmm-3): Update to 3.24.9. Change-Id: I63e4cf6d040ff7d147965d5320ab818ff553456b Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Vivien Kraus 2024-05-14gnu: cairo: Fix cross-compilation....* gnu/packages/gtk.scm (cairo)[arguments]: Add ‘fix-cross-compilation’ phase when cross-compiling. Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Zheng Junjie 2024-05-06gnu: graphene: Fix build on armhf-linux....* gnu/packages/gtk.scm (graphene)[arguments]: When building for armhf-linux add a configure-flag to disable neon optimizations. Change-Id: I42b412d3f7536180e959e268b68f2c292edda749 Efraim Flashner 2024-04-09Merge remote-tracking branch 'savannah/master' into mesa-updates...Change-Id: Iad185e2ced97067b3dff8fd722435a6c5e2c00e5 Christopher Baines 2024-04-02gnu: gtk: Fix tests on aarch64....* gnu/packages/gtk.scm (gtk)[arguments]<#:configure-flags>: Skip more failing tests known to fail. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I34d0f7521224b41072fcc0c35321935d1db927e0 Leo Nikkilä 2024-04-02Revert "gnu: gtk: Skip failing tests on aarch64-linux."...This reverts commit 76ed1e886ea790fc8562b355a0768a0f04889abb. The next commit does a better job of skipping the tests. Efraim Flashner 2024-03-31gnu: cairo: Update to 1.18.0....With this new release of cairo many old configure options were removed and now meson is used to build it. The defaults include the tee backend which we had previously enabled while the xml backend has been dropped from cairo completely. Old configure options where were commented out to be enabled have been removed as they no longer apply to version 1.18.0. The variable 'cairo' is now a hidden package to work around a dependency cycle where gtk-doc is needed to build the documentation (which itself depends on cairo). The new variable 'cairo-with-documentation' is now the public package and the module exports 'cairo' for use in other packages. This follows what was done for glib. * gnu/packages/gtk.scm: Export 'cairo'. (cairo): Update to 1.18.0. [source]: Remove 'patches' field. [properties]: Hide package. [outputs]: Remove (doc output is now in cairo-with-documentation). [build-system]: Change to meson-build-system. [arguments]: Add #:glib-or-gtk?. Remove old flags from #:configure-flags and add '-Dtests=disabled' to match #:tests?. [propagated-inputs]: Remove commented out packages. (cairo-with-documentation): New variable. (cairo-sans-poppler)[properties]: No longer set hidden as it is now inherited from cairo. (cairo-xcb)[properties]: Unhide (inherited from cairo). [arguments]: Remove obsolete #:configure-flags and properly inherit from cairo. * gnu/packages/patches/cairo-CVE-2018-19876.patch: Remove. * gnu/packages/patches/cairo-CVE-2020-35492.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove them. Change-Id: I2f4c953b23c6b32b1fafaf03db89d7a475fc6956 John Kehayias 2024-03-31gnu: python-pycairo: Update to 1.26.0....* gnu/packages/gtk.scm (python-pycairo): Update to 1.26.0. Change-Id: I7349bd0c68b061d0f3fe46db52b7fdc63acbd69b John Kehayias 2024-03-31gnu: gtk: Skip failing tests on aarch64-linux....* gnu/packages/gtk.scm (gtk)[arguments]: When building for aarch64-linux add a phase to skip a test which can't find the zink driver. Change-Id: I7b596309f1cbd555bd7ba889379d5b0bb245eabc Efraim Flashner 2024-03-24gnu: pango-1.90: Disable failing test....* gnu/packages/gtk.scm (pango-1.90)[source]: Disable failing test. Change-Id: Ib0f6dcd42c9475c4b543400f43836c2f3f8db16f Signed-off-by: Christopher Baines <mail@cbaines.net> Vivien Kraus 2024-03-16gnu: girara: Build with json-glib....* gnu/packages/gtk.scm (girara) [propagated-inputs]: Add json-glib. Change-Id: I5bfe5a516885153014fce1c6643ac5799f0100e1 Signed-off-by: Christopher Baines <mail@cbaines.net> Vivien Kraus 2024-03-10Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-03-09gnu: girara: Update to 0.4.3....* gnu/packages/gtk.scm (girara): Update to 0.4.3. Change-Id: I3c977cd33fa6d20fce3bb575ae2ad887b3061966 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail> Vivien Kraus 2024-03-09gnu: girara: Update style....* gnu/packages/gtk.scm (girara)[arguments]: Convert to list of G-Expressions. [native-inputs]: Move after arguments. [propagated-inputs]: Move after arguments. Change-Id: I79a6f59f6ea671433f1a66a10cb79203f0b9bbae Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail> Vivien Kraus 2024-03-03gnu: girara: Update to 0.4.2....* gnu/packages/gtk.scm (girara): Update to 0.4.2. Change-Id: Ib7daa73b5802c98b653f4513f6111dcad786b65f Efraim Flashner