aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages figlet)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public figlet
  (package
    (name "figlet")
    (version "2.2.5")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "ftp://ftp.figlet.org/pub/figlet/program"
                           "/unix/figlet-" version ".tar.gz"))
       (sha256
        (base32 "0za1ax15x7myjl8jz271ybly8ln9kb9zhm1gf6rdlxzhs07w925z"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases (delete 'configure))
       #:make-flags
       (list (string-append "prefix=" %output))))
    (home-page "http://www.figlet.org/")
    (synopsis "Make large letterforms out of ordinary screen characters")
    (description "FIGlet is a program for making large ASCII art letterforms
out of ordinary screen characters.")
    (license license:bsd-3)))
926537'>gnu: pre-commit: Update to 3.3.3....* gnu/packages/version-control.scm (pre-commit): Update to 3.3.3. Vinicius Monego 2023-07-16gnu: gitolite: Update to 3.6.13....* gnu/packages/version-control.scm (gitolite): Update to 3.6.13. Tobias Geerinckx-Rice 2023-07-20gnu: git: Skip failing test on the Hurd....* gnu/packages/version-control.scm (git)[arguments]: When building natively on the Hurd, add stage 'delete-tests/hurd'. Janneke Nieuwenhuizen 2023-07-07gnu: b4: Update to 0.12.3....* gnu/packages/version-control.scm (b4): Update to 0.12.3. Josselin Poiret 2023-07-02gnu: git: Update to 2.41.0....* gnu/packages/version-control.scm (git): Update to 2.41.0. [source]: Remove upstreamed patch. * gnu/packages/patches/git-header-cmd.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Tobias Geerinckx-Rice 2023-06-18gnu: b4: Update to 0.12.0...* gnu/packages/version-control.scm (b4): Update to 0.12.0 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Andy Tai 2023-06-13gnu: libgit2: Skip some tests on armhf-linux....* gnu/packages/version-control.scm (libgit2)[arguments]: When building for armhf-linux add a phase to skip some tests. Efraim Flashner 2023-06-12gnu: lfs-s3: Update to 0.1.2....* gnu/packages/version-control.scm (lfs-s3): Update to 0.1.2. [propagated-inputs] Remove go-github-com-spf13-cobra. Signed-off-by: Christopher Baines <mail@cbaines.net> Nicolas Graves 2023-05-14gnu: pre-commit: Update to 3.3.1....* gnu/packages/version-control.scm (pre-commit): Update to 3.3.1. Vinicius Monego 2023-05-11gnu: git: Update to 2.40.1 [security fixes]....Fixes CVE-2023-25652 and CVE-2023-29007. * gnu/packages/version-control.scm (git): Update to 2.40.1. (git-minimal)[arguments]: Rewrite to use gexps. In 'remove-unusable-perl-commands' phase, make "git-add--interactive" removal conditional. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2023-05-06gnu: gitile: Fix build....* gnu/packages/version-control.scm (gitile)[arguments]: Replace 'bootstrap' phase. [inputs]: Replace GNUTLS with GUILE-GNUTLS. Ludovic Courtès 2023-05-05gnu: git-crypt: Fix build issues on OpenSSL 3....* gnu/packages/version-control.scm (git-crypt)[arguments]: In 'build' phase, set 'CXXFLAGS'. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sergey Trofimov 2023-05-01gnu: git: Apply patch adding the --header-cmd feature....In preparation to fix <https://issues.guix.gnu.org/58813>. * gnu/packages/patches/git-header-cmd.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/version-control.scm (git) [source]: Apply patch. Maxim Cournoyer 2023-04-23Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-04-23gnu: Add lfs-s3....* gnu/packages/version-control.scm (lfs-s3): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> Nicolas Graves 2023-04-23gnu: git-lfs: Update to 3.3.0....* gnu/packages/version-control.scm (git-lfs): Update to 3.3.0. [arguments] Use gexp. Add phase fix-embed-x-net (publicsuffix/table.go doesn't work with symlinked data). [native-inputs] Add git-minimal. Add ruby-asciidoctor. [propagated-inputs] Add go-github-com-xeipuuv-gojsonschema, go-github-com-xeipuuv-gojsonreference, go-github-com-xeipuuv-gojsonpointer, go-golang-org-x-net, go-golang.org-x-sync-semaphore, go-github-com-ssgelm-cookiejarparser, go-github-com-rubyist-tracerx, go-github-com-olekukonko-ts, go-github-com-leonelquinteros-gotext, go-github-com-git-lfs-wildmatch-v2, go-github-com-git-lfs-pktline, go-github-com-git-lfs-go-netrc, go-github-com-git-lfs-gitobj-v2, go-github-com-dpotapov-go-spnego, go-github-com-avast-retry-go, go-github-com-mattn-go-isatty, go-github-com-pkg-errors, go-github-com-spf13-cobra. Signed-off-by: Leo Famulari <leo@famulari.name> Nicolas Graves 2023-04-23gnu: Add go-github-com-git-lfs-wildmatch-v2....* gnu/packages/version-control.scm (go-github-com-git-lfs-wildmatch-v2): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> Nicolas Graves 2023-04-23gnu: Add go-github-com-git-lfs-pktline....* gnu/packages/version-control.scm (go-github-com-git-lfs-pktline): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> Nicolas Graves 2023-04-23gnu: Add go-github-com-git-lfs-gitobj-v2....* gnu/packages/version-control.scm (go-github-com-git-lfs-gitobj-v2): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> Nicolas Graves 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-14Revert "gnu: subversion: Tentatively reinstate parallel tests."...This reverts commit 54ee868cbed729c3789c6121193a823d68557daa. Maxim Cournoyer 2023-04-12gnu: pre-commit: Update to 3.2.2....* gnu/packages/version-control.scm (pre-commit): Update to 3.2.2. Vinicius Monego 2023-04-03gnu: pre-commit: Update to 3.2.2....* gnu/packages/version-control.scm (pre-commit): Update to 3.2.2. Vinicius Monego