aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dc)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages sqlite)
  #:use-module (gnu packages tls)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public ncdc
  (package
    (name "ncdc")
    (version "1.22.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
                           ".tar.gz"))
       (sha256
        (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi"))))
    (build-system gnu-build-system)
    (inputs
     (list bzip2
           glib
           gnutls
           ncurses
           sqlite
           zlib))
    (native-inputs
     (list pkg-config))
    (home-page "https://dev.yorhel.nl/ncdc")
    (synopsis
     "Lightweight direct connect client with a friendly ncurses interface")
    (description
     "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
using ncurses.  It is known for its smaller footprint and ease of use.")
    (license license:x11)))
)....Ludovic Courtès 2015-01-13gnu: guile-ncurses: Build a UTF-8 locale for the tests....Mark H Weaver 2015-01-07gnu: guile: Depend on 'libltdl' rather than 'libtool'....Ludovic Courtès 2015-01-06gnu: guile: Apply fixes for arm....Mark H Weaver 2014-12-27packages: Add 'file-type' field to 'search-path-specification'....Ludovic Courtès 2014-11-18gnu: Fix cross-compilation issue in guile-json...John Darrington 2014-11-05gnu: Synchronize descriptions with the Womb....Ludovic Courtès 2014-10-29gnu: guile-ncurses: Update to 1.6....Ludovic Courtès 2014-10-26gnu: Some cleanup based on lint checkers....Eric Bavier 2014-09-29gnu: guile-ncurses: Update to 1.5....Ludovic Courtès 2014-09-22Merge branch 'core-updates'Ludovic Courtès 2014-09-19gnu: guile-charting: Update to 0.2.0....Ludovic Courtès 2014-09-16gnu: guile-charting: Modules correctly installed, guile-cairo propagated....Ludovic Courtès 2014-08-28Merge branch 'master' into core-updates...Mark H Weaver 2014-08-28gnu: Add Guile-Charting....Ludovic Courtès 2014-08-20Merge branch 'master' into core-updatesMark H Weaver 2014-08-20gnu: guile-2.0: Make 'bash' an input unconditionally....Mark H Weaver 2014-08-16gnu: guile-json: Update to 0.4.0....David Thompson 2014-06-25gnu: mcron: Upgrade to 1.0.8....Ludovic Courtès 2014-06-16gnu: guile-ncurses: Work around missing test files....Ludovic Courtès 2014-04-29gnu: guile-ncurses: Build with Unicode support....Ludovic Courtès 2014-04-28gnu: mcron: Upgrade to 1.0.7....Ludovic Courtès 2014-04-01gnu: guile-json: Install under .../site/2.0....Ludovic Courtès 2014-04-01gnu: Add guile-json....Cyril Roelandt 2014-03-22gnu: guile: Upgrade to 2.0.11....Mark H Weaver 2014-03-18gnu: guile: Upgrade to 2.0.10....Ludovic Courtès 2014-03-18gnu: Make libgc 7.4 the default....Ludovic Courtès 2014-01-25Merge branch 'master' into core-updatesLudovic Courtès 2014-01-22gnu: guile-2.0: Switch to libgc 7.4.0....Ludovic Courtès 2013-12-17gnu: gnu-build-system: Add CC_FOR_BUILD to configure flags....John Darrington 2013-12-04gnu: Move 'guile-ssh' to (gnu packages ssh)....Ludovic Courtès 2013-12-04gnu: Add Guile-SSH....Ludovic Courtès 2013-12-01gnu: Synchronize descriptions with 'gnumaint'.Ludovic Courtès 2013-10-09Synchronize package descriptions with the Womb....Ludovic Courtès 2013-10-09gnu: Use the 'patches' field of <origin>....Ludovic Courtès 2013-08-26gnu: Add Guile-Lib....Ludovic Courtès 2013-08-21gnu: guile-ncurses: Install modules under .../site/2.0....Ludovic Courtès 2013-07-03gnu: Add a "debug" output for some packages....Ludovic Courtès 2013-06-22utils: `set-path-environment-variable' calls `unsetenv' for empty values....Ludovic Courtès 2013-06-21build-system/gnu: Unify with (guix build-system gnu-cross-build)....Ludovic Courtès 2013-05-27gnu: guile: More cross-compilation tweaks....Ludovic Courtès 2013-05-26gnu: guile: Add Bash as an input, to permit cross-compilation....Ludovic Courtès 2013-05-12gnu: guile-reader: Install modules in the right place....Ludovic Courtès 2013-05-07gnu: guile-ncurses: Update to 1.4....Ludovic Courtès