aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages barrier)
  #:use-module (guix build-system cmake)
  #:use-module (guix utils)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module (guix download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages avahi)
  #:use-module (gnu packages check)
  #:use-module (gnu packages cpp)
  #:use-module (gnu packages curl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages xorg))

(define-public barrier
  (package
    (name "barrier")
    (version "2.4.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/debauchee/barrier")
             (commit (string-append "v" version))
             (recursive? #t)))
       (file-name (git-file-name name version))
       (sha256
        (base32 "19bwa9qidq2mxv1fkyxxc1xdmv3jx6bj35bkaaw70jzkblnfmlfs"))))
    (build-system cmake-build-system)
    (arguments
     (list
      #:configure-flags
      #~(list "-DBARRIER_USE_EXTERNAL_GTEST=ON")
      #:tests? #f ;; tests require a running x server
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'fix-null
            (lambda _
              (substitute* "src/lib/base/Event.h"
                (("#include \"common/stdmap\\.h\"")
                 "#include \"common/stdmap.h\"\n#include <cstddef>")))))))
    (native-inputs
     (list googletest pkg-config))
    (inputs
     (list avahi curl gulrak-filesystem libx11 libxtst openssl qtbase-5))
    (synopsis "Keyboard Video Mouse switch software")
    (description "@code{Barrier} is software that mimics the functionality of
a KVM switch, which historically would allow you to use a single keyboard and
mouse to control multiple computers by physically turning a dial on the box to
switch the machine you're controlling at any given moment.  Barrier does this
in software, allowing you to tell it which machine to control by moving your
mouse to the edge of the screen, or by using a keypress to switch focus to a
different system.")
    (home-page "https://github.com/debauchee/barrier")
    (license license:gpl2)))
span class='msg-avail'>...Fix the build as senn in <https://ci.guix.gnu.org/build/5804385/log/raw>. * gnu/packages/prometheus.scm (go-github-com-nbrownus-go-metrics-prometheus): Fix build. [arguments]: <#:phases>: Add 'fix-embed-files. Change-Id: I0164c81caf203d93cdc8d1745b5a15bf77be9fb5 Sharlatan Hellseher 2024-11-09gnu: go-github-com-prometheus-common-sigv4: Update to 0.1.0, fix build....Fix the build as seen in <https://ci.guix.gnu.org/build/5804380/log/raw>. * gnu/packages/prometheus.scm (go-github-com-prometheus-common-sigv4): Update to 0.1.0. [source]: Remove all submodules and keep the sources just for <github.com/prometheus/common/sigv4>. [origin]: Apply new style for "go-version->git-ref" using <#:subdir> key parameter. [arguments]: <#:phases>: Remove 'override-prometheus-common; add 'fix-embed-files. Change-Id: I69a37690baafbfca1a2e33ebdea957456a96b0e8 Sharlatan Hellseher 2024-11-09gnu: go-github-com-prometheus-statsd-exporter: Fix build....* gnu/packages/prometheus.scm (go-github-com-prometheus-statsd-exporter): Fix build [arguments]: <#:phases>: Rework 'copy-input-to-vendor-directory and 'remove-vendor-directory by consolidating and simplifying them into 'fix-embed-files. Change-Id: I5c255ea17dc9926bf9e2ea9a0a0e662afe9c2e5d Sharlatan Hellseher 2024-11-09gnu: go-github-com-prometheus-exporter-toolkit: Fix build....* gnu/packages/prometheus.scm (go-github-com-prometheus-exporter-toolkit): Fix build [arguments]: <#:phases>: Add 'fix-embed-editions-defaults-binpb phase; remove 'disable-failing-tests in favor of "-skip" test flags. [native-inputs]: Add go-google-golang-org-protobuf. Change-Id: If573aa261adc3a136a4907267d1427a9f9cfb4d9 Sharlatan Hellseher 2024-11-09gnu: go-github-com-prometheus-client-golang: Fix build....* gnu/packages/prometheus.scm (go-github-com-prometheus-client-golang): Fix build. [arguments]: <#:phases>: Add 'fix-embed-files. Change-Id: Ifdd422e4574291d7a101b28862bc129262b48196 Sharlatan Hellseher 2024-11-09gnu: go-github-com-prometheus-common: Fix build....* gnu/packages/prometheus.scm (go-github-com-prometheus-common): Fix build. [arguments]: <#:phases>: Add 'fix-embed-files. Change-Id: Ia213327d15288315b54b623c4a15837d7d895a69 Sharlatan Hellseher 2024-08-27gnu: go-github-com-prometheus-client-golang: Disable tests on non 64bit archi......As seen in CI <https://ci.guix.gnu.org/build/5483940/log/raw>. * gnu/packages/gnu/packages/prometheus.scm (go-github-com-prometheus-client-golang): Disable tests on non 64bit architecture. Change-Id: Ic2f23e1aec24e72056741d4f6fe1fa479bf5e60e Sharlatan Hellseher 2024-08-27gnu: go-github-com-prometheus-procfs: Disable tests on non x86_64 architecture....As seen in CI <https://ci.guix.gnu.org/build/5475510/log/raw>. * gnu/packages/prometheus.scm (go-github-com-prometheus-procfs): Disable tests on non x86_64 architecture. Change-Id: I5f8a4431110cd4b64a2310c2d0b8b0b789216e0d Sharlatan Hellseher 2024-08-27gnu: go-github-com-prometheus-common: Adjust tests for non x86_64 architecture....As seen in CI <https://ci.guix.gnu.org/build/5327084/log/raw>. * gnu/packages/prometheus.scm (go-github-com-prometheus-common) [arguments] <#:phases>: Adjust selection of Golang packages during 'check phase. Change-Id: I2dba887aeaf9268df135c1a0483023c08853d0c7 Sharlatan Hellseher 2024-08-25gnu: go-github-com-prometheus-procfs: Enable tests....* gnu/packages/prometheus.scm (go-github-com-prometheus-procfs): Enable tests. [arguments] <#:phases>: Add 'unpack-testdata and 'remove-testdata phases. Use custom 'check phase. Change-Id: Iae01ce9cb57748ce4b155e2b814dd69ff9ba5114 Sharlatan Hellseher 2024-08-25gnu: Add go-github-com-prometheus-statsd-exporter....* gnu/packages/prometheus.scm (go-github-com-prometheus-statsd-exporter): New variable. Change-Id: Ibb45cfd1d4b944d6c809305650df6c323bbf52e0 Sharlatan Hellseher 2024-08-25gnu: Add go-github-com-prometheus-exporter-toolkit....* gnu/packages/prometheus.scm (go-github-com-prometheus-exporter-toolkit): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I89d3a28a1f8ceab9ec3e8754582b2292205b3772 Leo Nikkilä 2024-07-25gnu: go-github-com-prometheus-procfs: Move to prometheus....* gnu/packages/golang.scm (go-github-com-prometheus-procfs): Move from here ... * gnu/packages/prometheus.scm: ... to here. Remove (gnu packages golang) module. * gnu/packages/golang.scm: Remove (gnu packages prometheus) module. * gnu/packages/prometheus.scm: Remove (gnu packages golang) module. Change-Id: I3dd26ebc80c0a9fad47cec9887d6f52ad21bdc45 Sharlatan Hellseher 2024-07-25gnu: go-github-com-nbrownus-go-metrics-prometheus: Move to prometheus....* gnu/packages/golang-xyz.scm (go-github-com-nbrownus-go-metrics-prometheus): Move from here ... * gnu/packages/prometheus.scm: ... to here. Change-Id: I02393dd3620d7c194c4bbba6404e5c0150f8448a Sharlatan Hellseher 2024-07-25gnu: go-github-com-prometheus-client-golang: Move to prometheus....* gnu/packages/golang.scm (go-github-com-prometheus-client-golang): Move from here ... * gnu/packages/prometheus.scm: ... to here. * gnu/packages/backup.scm: Add (gnu packages prometheus) module. * gnu/packages/golang-xyz.scm: Likewise. * gnu/packages/ipfs.scm: Likewise. * gnu/packages/irc.scm: Likewise. * gnu/packages/web.scm: Likewise. Change-Id: If3d78d31b1491f8a95616e59f50371c2914242d9 Sharlatan Hellseher 2024-07-25gnu: Add go-github-com-prometheus-common-sigv4....* gnu/packages/prometheus.scm (go-github-com-prometheus-common-sigv4): New variable. Change-Id: Id023eec48d48f53b70882809fad139362a48803c Sharlatan Hellseher 2024-07-25gnu: Add go-github-com-prometheus-common-assets....* gnu/packages/prometheus.scm (go-github-com-prometheus-common-assets): New variable. Change-Id: I75e9cea67883076d20aef6be5f144397bd4da4f8 Sharlatan Hellseher 2024-07-25gnu: go-github-com-prometheus-common: Move to prometheus....* gnu/packages/golang.scm (go-github-com-prometheus-common): Move from here ... * gnu/packages/prometheus.scm: ... to here. Change-Id: I344f9b5b62569b3a0fde6ed96621f409bb7350a9 Sharlatan Hellseher 2024-07-25gnu: Add go-github-com-mwitkow-go-conntrack....* gnu/packages/prometheus.scm (go-github-com-mwitkow-go-conntrack): New variable. Change-Id: I874b96a61ee116fee435e3817d84802fa48eacfe Sharlatan Hellseher 2024-07-25gnu: go-github-com-prometheus-client-model: Move to prometheus....* gnu/packages/golang-xyz.scm (go-github-com-prometheus-client-model): Move from here ... * gnu/packages/prometheus.scm: ... to here. * gnu/packages/golang.scm: Add (gnu packages prometheus) module. * gnu/packages/networking.scm: Likewise. Change-Id: Ibbfc4100dfe33f9524eee99a461e7760f06a8eb3 Sharlatan Hellseher 2024-07-25gnu: Add packages/prometheus module....* gnu/packages/prometheus.scm: New file. * gnu/local.mk: Add gnu/packages/prometheus.scm to the scope. Change-Id: Ie291afe3b4470c1681d3d77e62ffe2ee090d3a54 Sharlatan Hellseher