aboutsummaryrefslogtreecommitdiff
path: root/tests/guile/Makefile.am
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2023-12-07 22:17:53 +0100
committerWojtek Kosior <koszko@koszko.org>2023-12-12 21:17:04 +0100
commitc1d4d5b2b0ba2220bd31b20ea02eb4ec80bdc8ac (patch)
tree891616649df89735c96900737096790cd94aff10 /tests/guile/Makefile.am
downloadde-paul-records-c1d4d5b2b0ba2220bd31b20ea02eb4ec80bdc8ac.tar.gz
de-paul-records-c1d4d5b2b0ba2220bd31b20ea02eb4ec80bdc8ac.zip
Initial commit.
Diffstat (limited to 'tests/guile/Makefile.am')
-rw-r--r--tests/guile/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/guile/Makefile.am b/tests/guile/Makefile.am
new file mode 100644
index 0000000..4dd1658
--- /dev/null
+++ b/tests/guile/Makefile.am
@@ -0,0 +1,25 @@
+# SPDX-License-Identifier: CC0-1.0
+#
+# Copyright (C) 2023 Wojtek Kosior <koszko@koszko.org>
+
+GUILE_SOURCE_FILES = \
+ $(PACKAGE)-test.scm
+
+GUILE_OBJECT_FILES = $(GUILE_SOURCE_FILES:.scm=.go)
+
+
+TEST_EXTENSIONS = .scm
+
+SCM_LOG_DRIVER = $(top_builddir)/pre-inst-env $(GUILE_TEST_DRIVER)
+
+TESTS = $(GUILE_SOURCE_FILES)
+
+
+dist_noinst_DATA = $(GUILE_SOURCE_FILES)
+
+check_DATA = $(GUILE_OBJECT_FILES)
+
+MOSTLYCLEANFILES = $(GUILE_OBJECT_FILES)
+
+.scm.go:
+ $(top_builddir)/pre-inst-env $(GUILD) compile --output=$@ $<