aboutsummaryrefslogtreecommitdiff
path: root/tests/guile/Makefile.am
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2023-12-15 22:26:10 +0100
committerWojtek Kosior <koszko@koszko.org>2023-12-16 13:16:48 +0100
commitdac73785f73a91306a1c3eacbf04be720717ab76 (patch)
tree8636cfb50ec63d0e1e3d171cf3f723e1ff8769cd /tests/guile/Makefile.am
downloadcantius-dac73785f73a91306a1c3eacbf04be720717ab76.tar.gz
cantius-dac73785f73a91306a1c3eacbf04be720717ab76.zip
Initial commit.
Diffstat (limited to 'tests/guile/Makefile.am')
-rw-r--r--tests/guile/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/guile/Makefile.am b/tests/guile/Makefile.am
new file mode 100644
index 0000000..36d4eba
--- /dev/null
+++ b/tests/guile/Makefile.am
@@ -0,0 +1,27 @@
+# SPDX-License-Identifier: CC0-1.0
+#
+# Copyright (C) 2023 Wojtek Kosior <koszko@koszko.org>
+
+GUILE_SOURCE_FILES = \
+ $(PACKAGE)-test.scm
+
+GUILE_OBJECT_FILES = $(GUILE_SOURCE_FILES:.scm=.go)
+
+
+TEST_EXTENSIONS = .scm
+
+SCM_LOG_DRIVER = $(top_builddir)/pre-inst-env $(GUILE_TEST_DRIVER)
+
+TESTS = $(GUILE_SOURCE_FILES)
+
+
+dist_noinst_DATA = $(GUILE_SOURCE_FILES)
+
+check_DATA = $(GUILE_OBJECT_FILES)
+
+MOSTLYCLEANFILES = $(GUILE_OBJECT_FILES)
+
+.scm.go:
+ $(top_builddir)/pre-inst-env $(GUILD) compile --output=$@ $<
+
+EXTRA_DIST=.dir-locals.el