summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnton Agestam <git@antonagestam.se>2019-10-11 22:39:26 +0200
committerYury Selivanov <yury@edgedb.com>2019-10-11 16:39:26 -0400
commit8927b8157dbb26a557599f7236794977ca2da70e (patch)
tree44570c775da7ac83ad3cada5e6eb9e858aed685f /setup.py
parent197ceabc33c6629cfeae00ded1c4ed2244378927 (diff)
downloadimmutables-8927b8157dbb26a557599f7236794977ca2da70e.tar.gz
immutables-8927b8157dbb26a557599f7236794977ca2da70e.zip
fix: add package_data to setup.py (#14)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4e8dc6d..435397d 100644
--- a/setup.py
+++ b/setup.py
@@ -57,6 +57,7 @@ setuptools.setup(
url='https://github.com/MagicStack/immutables',
license='Apache License, Version 2.0',
packages=['immutables'],
+ package_data={"immutables": ["py.typed", "*.pyi"]},
provides=['immutables'],
include_package_data=True,
ext_modules=ext_modules,
: Add GUIX_ALLOW_OVERWRITE environment variable....Maxim Cournoyer 2022-12-16guix-install.sh: Directly exit in case of errors in chk_require....Maxim Cournoyer 2022-12-16guix-install.sh: Add missing "useradd" command....Maxim Cournoyer 2022-12-11guix-install.sh: Gracefully fail on | bash....Tobias Geerinckx-Rice 2022-12-09guix-install.sh: Authorize all project build farms at once....Tobias Geerinckx-Rice 2022-11-16guix-install.sh: Expand mktemp template for busybox compatibility....Maxim Cournoyer 2022-11-14guix-install.sh: Remove unnecessary XDG_DATA_DIRS export....Prafulla Giri 2022-11-08guix-install.sh: Run guix.sh script in /etc/profile.d last....Konrad Hinsen 2022-10-16guix-install.sh: Cosmetically tweak non-interactive output....Tobias Geerinckx-Rice 2022-10-16guix-install.sh: Warn if we suspect dodgy automation....Tobias Geerinckx-Rice 2022-10-16guix-install.sh: Treat all uncaught errors as fatal....Tobias Geerinckx-Rice 2022-10-16guix-install.sh: Suggest what to do if fetching OpenPGP key(s) fails....Tobias Geerinckx-Rice 2022-10-16guix-install.sh: Time out fetching OpenPGP keys....Tobias Geerinckx-Rice 2022-10-11guix-install.sh: Restore compatibility with "yes" invocation....Maxim Cournoyer 2022-10-07guix-install.sh: Add Bash prompt customization option....Maxim Cournoyer 2022-10-07guix-install.sh: Introduce 'die' utility function....Maxim Cournoyer 2022-10-07guix-install.sh: Improve prompt_yes_no procedure....Maxim Cournoyer