aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2022-07-09 09:03:36 +0200
committerWojtek Kosior <koszko@koszko.org>2022-07-09 09:03:36 +0200
commit9f7f7386c7fe49b249f6dd8c558266ce65e407dd (patch)
treecaa07112b88c6d6b044bf3172f7907d1bd65cdd9 /pyproject.toml
parenta45bb607c2d3900b9151fa0bc45d97f7c28e736b (diff)
downloadimmutables-9f7f7386c7fe49b249f6dd8c558266ce65e407dd.tar.gz
immutables-9f7f7386c7fe49b249f6dd8c558266ce65e407dd.zip
New upstream version 0.18debian-upstream
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e9018e7
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,25 @@
+[project]
+name = 'immutables'
+requires-python = ">=3.6"
+
+[build-system]
+requires = ["setuptools>=42", "wheel"]
+build-backend = "setuptools.build_meta"
+
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = "--capture=no --assert=plain --strict-markers --tb=native --import-mode=importlib"
+testpaths = "tests"
+filterwarnings = "default"
+
+[tool.mypy]
+incremental = true
+strict = true
+
+[[tool.mypy.overrides]]
+module = "immutables.map"
+ignore_errors = true
+
+[[tool.mypy.overrides]]
+module = "immutables._testutils"
+ignore_errors = true