aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..345febc
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,20 @@
+#!/usr/bin/env python3
+# SPDX-License-Identifier: CC0-1.0
+
+# Copyright (C) 2022 Wojtek Kosior <koszko@koszko.org>
+#
+# Available under the terms of Creative Commons Zero v1.0 Universal.
+
+import setuptools
+
+from setuptools.command.build_py import build_py
+
+class CustomBuildCommand(build_py):
+ '''
+ The build command but runs babel before build.
+ '''
+ def run(self, *args, **kwargs):
+ self.run_command('compile_catalog')
+ super().run(*args, **kwargs)
+
+setuptools.setup(cmdclass={'build_py': CustomBuildCommand})