aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..623201c
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: CC0-1.0
+
+# Copyright (C) 2022 Wojtek Kosior <koszko@koszko.org>
+#
+# Available under the terms of Creative Commons Zero v1.0 Universal.
+
+[build-system]
+build-backend = "setuptools.build_meta"
+requires = ["setuptools>=44", "wheel", "setuptools_scm>=5.0", "babel"]
+
+[tool.setuptools_scm]
+write_to = "src/hydrilla/server/_version.py"
+
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = "-ra -q"
+testpaths = [
+ "tests"
+]