aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..76c1b3d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#! /usr/bin/make -f
+
+# SPDX-License-Identifier: CC0-1.0
+
+# Hydrilla's debian/rules file
+#
+# Copyright (C) 2021,2022 Wojtek Kosior
+#
+# Available under the terms of Creative Commons Zero v1.0 Universal.
+
+export DH_VERBOSE = 1
+export PYBUILD_NAME = hydrilla
+export PYBUILD_TEST_PYTEST = 1
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_install:
+ dh_auto_install
+ # Namespaces. python3-hydrilla.builder package will provide the
+ # __init__.py file.
+ for DIR in ./debian/python3-hydrilla/usr/lib/python*; do \
+ rm -f $$DIR/dist-packages/hydrilla/__init__.py; \
+ done